-2

I recently bought a RPI2 to play with; at first I've installed OSMC and RetroPie in dual boot, but now I had to switch back to Raspbian to setup a local webserver. The problem is that I'm actually unable to use the SSH connection from my MB Pro or Android phone. The RPI is connected to my WLAN and is able to connect outside my lan (pinging google works flawlessly) but not inside my lan (pinging my MBP is impossible). The raspberry is able to self-ssh. I've tried googling the issue but no solution has been found by now... One last thing, i've tried sniffing my lan with lanscan and the RPI seems not to be connected to the lan even when actually connected LOL. Any idea?

  • Did you enable SSH in sudo raspi-config? – nagyben Sep 9 '15 at 13:52
  • ssh is enabled by default, is a fresh install... anyway i reenabled in raspi-config, just to doublecheck – Vinz29 Sep 9 '15 at 17:08
0

Seems like more of a problem with the network.

Is the Pi in the same network/subnet even?

check with :

$ ifconfig

check your router should there be a discrepancy.

  • checked on the router, they are connected to the same network, i don't have a subnet... it.tinypic.com/r/uvg9y/8 – Vinz29 Sep 9 '15 at 11:37
  • check your firewall settings on the Pi, mac and router, perhaps one of them is blocking. – Havnar Sep 9 '15 at 12:46
  • do you know where the pis firewall config are? mac and router should be fine, when using OSMC on RPI everything was fine... anyway i cannot use ssh even from PI to MBP... – Vinz29 Sep 9 '15 at 17:09
0

I checked the interfaces file and I found two wlan interfaces instead of one. The file was

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
wireless-power off

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

I changed to:

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
wireless-power off

#auto wlan1
#allow-hotplug wlan1
#iface wlan1 inet manual
#wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

using the command sudo nano /etc/network/interfaces you could delete the wlan1 part, I commented just for caution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.