4

I have a 3.5" display. It works fine, but since the display is small, most of the windows cannot appear on the screen because they are larger.

The current resolution is fine (it's default), but is it possible to force it to display all the elements on the screen a little bit smaller? That would help to get some more space.

How can I do that?

1

It is window manger's + application issue. Application authors may have set default window's sizes too big.

You may check your window manager's documentation to find options to resize windows. Or move to tiling window managers to have windows always fit your screen.

  • But I really want to make everything smaller. In Ubuntu I have a scale option which does this. – Ionică Bizău Sep 11 '15 at 8:18
0

I have had this problem to. For most windows, you can simply drag it into you see the maximize button and click that, then it fits the screen. For ones without a maximize button, such as Python games, your out of luck. :-(

  • I expect there should me a more native way for resizing everything. One layer is the resolution and another one is the scaling. I need to modify the scaling most probably. – Ionică Bizău Sep 11 '15 at 15:11
  • I don't think there is, all though I will try to do some extensive research tomorrow. – Triforcey Sep 12 '15 at 4:16
0

As mentioned by kassak, this issue is down to the window manager and the individual applications. There's not much we can do for the application outside of getting the source code and modifying them to work at smaller sizes.

We can deal with the window manager though, what you need is either a tiling window manager, or one that can control the DPI or scaling. I have no experience with the former, but for the latter I recommend xfce4, it's very light weight, so the Pi will handle it fine, and it has a settings manager window which wraps around all of the various settings editors, this means that if the setting you want is off screen you can scroll to access it, even if the developer set a fixed window size.

Instructions for how to install xfce4 can be found quite easily, but I won't link so the links don't go stale.

To change the DPI/scaling will depend on the window manager you choose. For xfce4 go:

  • Applications menu (should be top left by default)
  • Settings
  • Settings Editor
  • Appearance
  • Fonts Tab
  • Tick "Custom DPI Setting"
  • Change the number to the right to what feels best to you
  • Thanks! Maybe try to summarize here how to do that scaling you're talking about? It would help. – Ionică Bizău Mar 11 '16 at 14:56
  • Wow, I actually forgot to put that in, whoops! – Owen Tourlamain Mar 11 '16 at 15:07
  • You can edit your answer and add clear steps how to do it. :) – Ionică Bizău Mar 11 '16 at 15:08
0

There are some DPI related settings that you can try from this post:

https://stackoverflow.com/questions/49688781/dpi-scaling-on-nixos-with-lightdm-xmonad

I haven't tested them, but you can try one at a time to see which help. Bear in mind you may need to restart the X-Windows to get the settings to take effect.

Copied here for ease of reference:

✓ services.xserver.dpi = 180; (sets xserver flag)

✓ .Xresources settings

Xft.dpi: 180
Xft.autohint: 0
Xft.lcdfilter:  lcddefault
Xft.hintstyle:  hintfull
Xft.hinting: 1
Xft.antialias: 1
Xft.rgba: rgb

✓ export GDK_SCALE=2

✓ export GDK_DPI_SCALE=0.5

✓ export XCURSOR_SIZE=32

✓ export QT_AUTO_SCREEN_SCALE_FACTOR=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.