1

I followed this guide to install Raspbian on an SD card. Now, I want to access the SD card to modify a few files, before plugging the card into my RasPi. In the end, I ran something like,

sudo dd bs=4M if=2015-05-05-raspbian-wheezy.zip of=/dev/mmcblk0

I'm running Kubuntu 15.04 and I just can't access the SD card. I tried to mount the SD card by writing

sudo mount /dev/mmcblk0 /mnt/raspi-fs

which results into

mount: wrong fs type, bad option, bad superblock on /dev/mmcblk0,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

Running dmesg | tail gives

[  599.510979] mmc0: new high speed SDHC card at address 1234
[  599.511303] mmcblk0: mmc0:1234 SA16G 14.4 GiB 
[  599.513857]  mmcblk0: unknown partition table

What am I supposed to do to mount the FS and access the root directory of my Pi?

  • OMG, I'm so sorry. Using unzip prior to dd might be a good idea. – PhilippVerpoort Sep 11 '15 at 19:14
  • That, and you might want to mount a specific partition (e.g. /dev/mmcblk0p1) instead of the entire SD card device (/dev/mmcblk0) – Phil B. Sep 11 '15 at 22:43
1

As mentioned, you need to unzip the file to produce an img to write to the card.

It is unlikely that the SD card would be /dev/mmcblk0. Paste the output of df -h as suggested in the guide.

Running dd risks overwriting your system.

  • It was correct. Everything went well after doing the nice unzip trick. – PhilippVerpoort Sep 12 '15 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.