0

I am new to Raspberry Pi. I have a headless Pi running noobs on it. The Pi is connected to a router via an ethernet cable and I am ssh'ing into it via wi-fi from a PC.

I am following this tutorial: How to Setup Wi-Fi On Your Raspberry Pi via the Command Line

However, I think my Pi's interface file is different than it's mentioned in this tutorial. I tried to mess around but then, even my ethernet connection breaks and I have to reinstall the entire operating system on Pi.

Here's the link for the file containing links of all the snapshots, which you may require.

Please help me out with the correct configurations I need to make in the interface file.

P.S. I am absolute novice, I don't know about networking (Just started working on this kinda stuff). So it would be great if you clearly mention the correct configuration in answer plus changes I have to make in wpa_supplicant.conf

I've tried my best to make question thorough.

Sorry, I had to mention links in other file, They didn't let me post more than two links at a time.

Thanks a lot for your hardwork in solving this problem in advance..!

EDIT 1

The links to screen snapshots might not be working before, now the link file contains updated links, which point directly to images.

EDIT 2

I haven't changed any content of any file, I have reinstalled the operating system. I just wanted to know what's the problem.

  • Could this problem be caused by missing drivers ?

It does not automatically install the wi-fi adapter although I can see it in dmesg as being detected as a wlan device.

  • The default Raspbian desktop has a wifi set up button. Why did that not work? Perhaps your model of dongle is not supported. Have you googled for your dongle and Raspberry Pi? – joan Sep 12 '15 at 15:35
  • No i guess there's not any "wifi-config" icon – Salim Shamim Sep 12 '15 at 16:05
1

Unfortunately the Raspbian released in May 2015 changed the way WiFi works. This makes all the existing tutorials obsolete.

https://www.raspberrypi.org/documentation/configuration/wireless/README.md should work, but assumes you have a monitor. I suggest you borrow one to setup.

Setting up /etc/wpa_supplicant/wpa_supplicant.conf as described may work IF YOU HAVEN'T ALREADY CHANGED /etc/network/interfaces following the existing tutorials.

  • It doesn't shows any wireless network adapter, this is what i am trying to do. I mentioned the link to the adapter i've been using. It says it's linux compatible though. – Salim Shamim Sep 13 '15 at 5:38
  • Whatever "it" is you haven't given us any detail. What are you trying? What have you changed? You have given no detail of what version you are using, and you seem reluctant to tell us what adapter. What does lsusb show? – Milliways Sep 13 '15 at 7:02
  • well most of the information is in the link file i shared above, and here's "lsusb" imgur.com/9EIyaIn and "It" is raspbian, I am sorry of not being enough clear. Here's the link of adapter I am using imgur.com/FtkBmb7 (Seller mentions that this adapter works with raspberri Pi) Please refer the link file i've shared in question it may contain some information, you might need :) – Salim Shamim Sep 13 '15 at 8:58
  • And the raspbean version is I thing 14.1 , file says Noobs V1_4_1 and pi is raspberry pi 2 model B – Salim Shamim Sep 13 '15 at 9:05
  • 1
    The normal practice on this site is to post TEXT. You should also update your original question, NOT add comments. I did look at one of your links, and I find it illegible. You still haven't posted the contents of files you changed. – Milliways Sep 14 '15 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.