I am new to this, so please help me out. I just brought a wifi adapter to plug into my pi and use it wirelessly connect to router. But, I am not sure it supports, well I am using headless pi, and when using dmesg it gives out following output related to wlan

new high-speed USB device number 5 using dwc_otg
New USB device found, idVendor=148f, idProduct=7601
New USB device strings:Mfr=1,Product=2, SerialNumber=3
Product: 802.11 n WLAN
Manufacturer: MediaTek
SerialNumber: 1.0

Well, everything looks fine, but I am not able to set it up, Since new version of raspbean made all tutorials obsolete(I've tried them, It doesn't work). And, My Pi's Desktop(Which i access through vnc server) also not shows any wifi config utility. I don't how to set it up. Please guide my thoroughly cause I am absolute novice and let me get this straight.

How do i set up that Wireless Adapter.!! step by step

PS These tutorials didn't worked: https://www.raspberrypi.org/documentation/configuration/wireless/README.md http://www.howtogeek.com/167425/how-to-setup-wi-fi-on-your-raspberry-pi-via-the-command-line/

No Network icon on upper right corner of raspberry pi's desktop.

Using Pi headless, Pi is connected to the router via ethernet and my pc is connected to router via wifi, and i am sshing into it using putty

  • It is quite possible that you're using a wifi adapter which is not supported by raspbian by default. You may have to install drivers explicitly to make it work. Can you give us out put of lsusb command ? It will help us understand which wifi adapter you're using. Also, a link of one that you're using can help as well. Sep 13 '15 at 6:44
  • yeah this is the device i am using imgur.com/FtkBmb7 in comments, the seller do actually mentions that it works with pi and here's the lsusb imgur.com/9EIyaIn the last one with the ralink tech. is the device i think. Sep 13 '15 at 8:47

The 7601 has long caused problems on the Raspberry Pi, requiring special driver builds.

Those days seem to be coming to an end.

The latest kernels (and Raspbian) have a suitable driver but you need to download some firmware.

sudo wget https://github.com/porjo/mt7601/raw/master/src/mcu/bin/MT7601.bin -O /lib/firmware/mt7601u.bin

See this Raspberry Pi org post for details.

Once you have done that, and rebooted, the system should see your dongle. You can then follow one of the generic wifi tutorials if it is not immediately usable.

Not the answer you're looking for? Browse other questions tagged or ask your own question.