2

I have a Raspberry Pi like access point all is fine. I usually turn it on without monitor, keyboard nor mouse. The problem I have is that if the Raspberry Pi is not used for some time and then you try to connect to its access point you can't. The Raspberry Pi access point is shown on the list of my devices that I usually connect there but you can't connect. Now I detected when I leave it connected with a mouse, keyboard and monitor to check what happen I note something. When the sleep happens and of course you can't connect if I move the mouse nothing happens but if I touch any key of the keyboard the image of the Raspberry comes up from blank and when comes up all text on screen you can connect to the access point. Then is very clear that something is sleeping here and when you touch the keyboard wake up and all is perfect again.

I tried to do each technique described here and nothing:
https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=18200

My Wi-Fi USB adapter is RTL 8188CUS with long range antenna. I'm using Raspbian. I heard that is possible that some Wi-Fi adapters sleep. Anything anyone know what could be the problem or how can I avoid the sleeping of whatever is causing the problem?

  • try adding the following wireless-power off to your /etc/network/interfaces file and then reboot – Steve Robillard Sep 13 '15 at 23:44
  • I have that file like this:auto lo iface lo inet loopback #auto eth0 #allow-hotplug eth0 iface eth0 inet dhcp #auto wlan0 allow-hotplug wlan0 wireless-power off iface wlan0 inet static address 192.168.42.1 netmask 255.255.255.0 #wireless-power off #iface wlan0 inet manual #wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf I changed like you see wireless-power off but I have openvpn and after add wireless-power off stopped work open VPN simply you can't connect to the acces point. I followed this tutorial to make open openvpn connection: blog.frd.mn/raspberry-pi-vpn-gateway – coerrace Sep 14 '15 at 1:17
  • Also I added wireless-power off after: iface wlan0 inet static address 192.168.42.1 netmask 255.255.255.0 And here in this case after net ask line you can connect to access point but not mask the IP openvpn and to check Suso service openvpn status say is not working openvpn. If I remove totally wireless-power off all works perfect in my system masking IP and connecting without any issue but the sleep begins. Any other suggestion? – coerrace Sep 14 '15 at 1:23
  • Have you sudo apt-get update' followed by 'sudo apt-get upgrade' ? Followed by a reboot. I have a different wifi adapter, but that solved the same symptoms for me. – Tyson Sep 14 '15 at 1:30
  • in my last comment Suso=sudo And yes I made 2 days ago the update and upgrade. Here if you add the command before iface command crash and simply you can't connect to acces point that creates that raspberry. If you place the command after 255.255.255.0 line you can connect to acces point but openvpn service stop working. – coerrace Sep 14 '15 at 1:47
0

This same problem happened to me, check here: https://www.raspberrypi.org/forums/viewtopic.php?t=61665

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.