1

With my rasp Pi, I made a Wifi AP (on wlan0) and I keep the raspberry connected to internet (eth0). The Rasp is not only used for surfing the public web, but also to get sensitive datas on one server.

So I tunnelled it like this :

[users/clients] <==wifi/wlan==> [[Rasp]] <==VPN/eth==> [Server/Data] <====> WWW

But when I run openvpn & the config, I lose DNS:

  • if openVPN is off : clients enter www.example.com and get it displayed
  • if openVPN is on : clients enter www.example.com and after 10 seconds (timeout) they get "DNS_PROBE_ERR_NO_INTERNET" . If they enter IPs, they dont get this issue, it works as usual.

I used isc-dhcp-server (/etc/dhcp/dhcpd.conf) to manage clients routing, dhcp and DNS (8.8.8.8, 8.8.4.4).

IP forwarding is 1.

To sum up, launching VPN breaks the DNS, actually breaks INTERNET FORWARDING - more generally -. I tried to use bind9, no success.

How can I solve it ?

closed as off-topic by Ghanima, Milliways, Kachamenus, mpromonet, ArchHaskeller Oct 19 '15 at 23:22

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be specific to the Raspberry Pi within the scope defined in the help center." – Ghanima, Milliways, Kachamenus, mpromonet, ArchHaskeller
If this question can be reworded to fit the rules in the help center, please edit the question.

  • After more investigations: It is not a matter of VPN. There is "NO INTERNET" for the Wifi AP clients . Since DNS are Google ones (online), obviously there is no more DN solving. – 3pic Sep 17 '15 at 7:22
  • 1
    Does your comment mean you solved this? If yes, then please put this in an answer OR, if you think the question has no value, delete your original question – Phil B. Oct 18 '15 at 15:02
0

This probably belongs on ServerFault or SuperUser - this is an OpenVPN question, not a Raspberry Pi one.

The short answer is probably that your routing with the VPN up has changed sufficiently that you can't reach the DNS server anymore. You should look at your routing table before/after launching the VPN, and then modify the config as necessary to fix the issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.