I am using the last Raspbian distro and having some issues using Tmux.

When I ssh into the RPi, and if I change to tty2 it works fine, but for tty1 it won't draw anything.

After pressing enter, it seems to just stop rendering the screen. All in backend is working fine since I can see the screen update in a ssh session on other machine when I am key pressing on tty1 on the RPi.

I uploaded a Youtube video that shows the problem. I was thinking how can the Raspberry be showing up top. Isn't tty only text? So there must be gfx layer on top of this tty that is causing this bug?

Anyone seen and fixed it? Or know what the problem might be?

  • Strange, not sure I understand? So it renders to start with and then stops working? – Jivings Nov 19 '12 at 20:16
  • no it never renders anything in tty1, i press enter after ~tmux attach it just stops updating the screen, not drawing the first pane or any thing. – Darkmage Nov 20 '12 at 8:10
  • updated post with a video showing the problem. – Darkmage Nov 20 '12 at 18:46
  • Nice video, but I'm afraid I don't know enough about tmux to make a suggestion. This is something I would take to the tmux community. You should be able to find them on IRC (#tmux on Freenode). – Jivings Nov 20 '12 at 19:01

I had the same problem. I assume you were also using auto-login. I disabled auto-login and tmux then worked from tty1. So, my auto-login was defective:-( I did some more searching and found a different way to start without a username or password. I needed this because I also what to ssh to the RPi so I do not need to have a monitor attached to it. Here is the link:

Auto-login with GUI disabled in Raspbian

Here are three lines from my /etc/inittab file. The first is the default, that requires a username and a password. The second is the auto-login that worked for logging in but fails for running tmux. The last line is the one that lets me auto-login AND works with tmux:-)

#1:2345:respawn:/sbin/getty --noclear 38400 tty1

#1:2345:respawn:/bin/login -f pi tty1 /dev/tty1 2>&1

1:2345:respawn:/sbin/getty --autologin pi --noclear 38400 tty1

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.