-1

I am using MediaTek 7610 wifi dongle , the dongle is getting detected by the rasbian but when I try ifconfig command , the wlan interface is not listed .I have attached the screen shot of the configs. I hope it helps. If any more details are required please do let me know. Any help is appreciated. Thanks. enter image description here

enter image description here

enter image description here

3
  • What does your /etc/network/interfaces contain?
    – joan
    Sep 17 '15 at 12:45
  • @joan I have added the contents of interfaces file.
    – jaycyborg
    Sep 17 '15 at 17:53
  • 1
    Could you edit your question and paste the actual text into the question, in lieu of photographs/screenshots? It makes it easier to search for the question. Thanks. Sep 20 '15 at 20:50
5

I am using the same dongle without problems.

I did two things.

  1. sudo rpi-update
  2. sudo wget https://github.com/porjo/mt7601/raw/master/src/mcu/bin/MT7601.bin -O /lib/firmware/mt7601u.bin

lssub reports

Bus 001 Device 004: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter

iwconfig reports

wlan0     IEEE 802.11bgn  ESSID:"myessid"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:16:41:18:9D:1F   
          Bit Rate=11 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=53/70  Signal level=-57 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1233   Missed beacon:0

dmesg reports

[   15.869703] usb 1-1.5: reset high-speed USB device number 4 using dwc_otg
[   15.972604] mt7601u 1-1.5:1.0: ASIC revision: 76010001 MAC revision: 76010500
[   15.982453] mt7601u 1-1.5:1.0: Firmware Version: 0.1.00 Build: 7640 Build time: 201302052146____
[   16.397793] mt7601u 1-1.5:1.0: Warning: unsupported EEPROM version 0d
[   16.397834] mt7601u 1-1.5:1.0: EEPROM ver:0d fae:00
[   16.692923] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   16.698545] usbcore: registered new interface driver mt7601u

uname -a reports

Linux harry 4.1.6+ #810 PREEMPT Tue Aug 18 15:19:58 BST 2015 armv6l GNU/Linux
11
  • except one difference , I am using Linux Raspberry pi 4.1.7-v7+ arm7l , does that require any changes? because I tried exactly the same steps but it still didn't get listed.
    – jaycyborg
    Sep 18 '15 at 1:09
  • It started working :) , earlier I did wget and then rpi-update but this time I first did rpi-update and then did wget from GitHub as suggested by you . Not sure what difference it made , it started working now . Thanks.
    – jaycyborg
    Sep 18 '15 at 4:14
  • @jaycyborg I should point out that the MT7601 driver can crash under heavy network load on the Pi2. I believe the cause has been identified and a fix is known. I don't know how long the fix will take to appear in the kernel. This only affects the multi-core Pi2.
    – joan
    Sep 18 '15 at 4:33
  • Oops that's sad .. Thanks for letting me know , I will keep an eye on that and will update once the fix is available .
    – jaycyborg
    Sep 18 '15 at 4:37
  • @jaycyborg The issue github.com/raspberrypi/linux/issues/1131 has a fix in the September 17th 2015 kernel release. So if you do another sudo rpi-update it may be fixed.
    – joan
    Sep 18 '15 at 6:59
0

Looks like there is a wifi driver loaded.

To list available interfaces, you should use:

ifconfig -a
  - OR -
ip link

Just plain ifconfig lists only interfaces which are in an "up" state, which by default wifi probably is not, particularly if ethernet is already connected.

10
  • tried ifconfig -a , posted the contents for your reference.
    – jaycyborg
    Sep 17 '15 at 18:20
  • Seems the driver does not work then -- have a look at this answer to do with the same chipset: raspberrypi.stackexchange.com/a/36377/5538
    – goldilocks
    Sep 17 '15 at 18:29
  • Thanks for your immediate reply.The current MT7601 binary was part of the updated raspbian kernel, it was not installed manually . Do you still want me to try with the blob on github as suggested by that post?
    – jaycyborg
    Sep 17 '15 at 18:39
  • Up to you. I haven't used that chip, I just remembered the question from the other day. The entry point to that git repo says it is obsolete as of kernel 4.2, but I don't think Rasbian is on 4.2 yet; you can check with uname -r.
    – goldilocks
    Sep 17 '15 at 18:44
  • I tried , still same result :( not getting listed but getting detected and listed when using command lsusb. No issues with the dongle , I have tried it on my Mac it works perfectly. So I guess it must be with the driver.
    – jaycyborg
    Sep 17 '15 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.