0

This question already has an answer here:

My raspberry pi 2 is connected to my Windows 8 laptop with an ethernet cable. I have DHCP, Bitvise server, and Putty all installed and running on my laptop. I can connect to my pi using putty and all works well. Every time I run ping google.com on putty I get an unknown host error. I've been through tons of tutorials and searched everywhere I can't get my pi to share the internet from my laptop.

I've set the sharing to enabled on my Wifi network connection properties. I have the Ethernet's IPv4 set to 192.168.137.1. If I run sudo cat /etc/network/interfaces I get the following:

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

I have tried every suggestion written on different forums and still I can't get internet working on my pi. Can someone please tell me what to do or what config changes I need to make to get this working?

marked as duplicate by Milliways, ArchHaskeller, mpromonet, Wilf, Jacobm001 Oct 6 '15 at 1:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

It sounds like you aren't getting DHCP DNS from your laptop, maybe put google dns in resolve?

echo "nameserver 8.8.8.8" >> /etc/resolve.conf

I would doublecheck your getting dhcp from your laptop on your PI, can you ping the windows 8 IP from the PI?

can you ping 8.8.8.8? can you ping google.com?

Check out this tutorial also, https://4sysops.com/archives/how-to-share-wi-fi-in-windows-8-with-internet-connection-sharing-ics/

Not the answer you're looking for? Browse other questions tagged or ask your own question.