1

After I had not the best experience with my wifi adapter, I want to buy a new adapter: I saw on a website the Asus USB-N10 Nano.

I'm using Raspbian on my Raspberry Pi 2. Will this adapter work with the Raspberry Pi?


Here is the output of lsmod and lsusb while this very adapter is connected and working properly (@goldilocks asked for it):

$ lsmod
Module                  Size  Used by                                                                                                                                                            
cfg80211              420690  0                                                                                                                                                                  
rfkill                 16659  1 cfg80211                                                                                                                                                         
fbtft_device           27517  0                                                                                                                                                                  
flexfb                 12647  2                                                                                                                                                                  
fbtft                  27628  2 flexfb,fbtft_device                                                                                                                                              
fb_sys_fops             1149  1 fbtft                                                                                                                                                            
syscopyarea             2789  1 fbtft                                                                                                                                                            
sysfillrect             3313  1 fbtft                                                                                                                                                            
sysimgblt               1837  1 fbtft                                                                                                                                                            
i2c_dev                 6047  0                                                                                                                                                                  
snd_bcm2835            19769  3                                                                                                                                                                  
snd_pcm                74825  1 snd_bcm2835                                                                                                                                                      
snd_seq                53561  0                                                                                                                                                                  
snd_seq_device          3650  1 snd_seq                                                                                                                                                          
snd_timer              18157  2 snd_pcm,snd_seq                                                                                                                                                  
snd                    52116  11 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device                                                                                                            
ads7846                11413  0                                                                                                                                                                  
hwmon                   2927  1 ads7846                                                                                                                                                          
8192cu                528485  0                                                                                                                                                                  
joydev                  9047  0                                                                                                                                                                  
bcm2835_gpiomem         2995  0                                                                                                                                                                  
i2c_bcm2708             5014  0                                                                                                                                                                  
spi_bcm2835             7248  0                                                                                                                                                                  
w1_gpio                 3473  0                                                                                                                                                                  
evdev                  10232  6                                                                                                                                                                  
wire                   25640  1 w1_gpio                                                                                                                                                          
cn                      4656  1 wire                                                                                                                                                             
uio_pdrv_genirq         2966  0                                                                                                                                                                  
uio                     8235  1 uio_pdrv_genirq                                                                                                                                                  
$ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.                                                                                                                                     
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub                                                                                                                                   
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.                                                                                                                                     
Bus 001 Device 004: ID 0b05:17ba ASUSTek Computer, Inc.                                                                                                                                          
Bus 001 Device 005: ID 0c45:7000 Microdia  
  • Note that performance of teeny-tiny-nano-wifi adapters can be badly affected (moreso than the larger units) by having metal things nearby - especially in the other usb ports – John La Rooy Sep 24 '15 at 5:58
  • @JohnLaRooy But then, what is the alternative? I liked it because it's small. – Ionică Bizău Sep 24 '15 at 6:48
  • If you are happy with the range/speed/stability etc. then there is no problem. – John La Rooy Sep 24 '15 at 6:54
  • @JohnLaRooy I ordered it because it was kind of cheap and was having good reviews. Just arrived and configured the router and password and everything works fine. Pretty happy with it. :D – Ionică Bizău Sep 28 '15 at 14:22
4

According to this page, there are two version of that adapter:

  • One uses a Realtek 8191su chip, for which the rtl8192cu driver from fairly recent kernels supposedly works (the USB ID is in the source1); I checked 4.1.5 and it is there, but not in 3.19. I think the current default kernel, if you use rpi-update is 4.1.7, so this should be okay.

  • The other uses a MediaTek MT7601U, for which there is a driver in the latest pi kernel, but you would have to build that yourself or wait a few weeks until it becomes the default.

Unfortunately you will not be able to tell which one this is by looking at the box or an online ad. You have to stick it in a machine and get the USB ID (in this case, either 0b05:17ba or 0b05:17d3).

My advice WRT wifi adapters is to buy them from a store and not online if possible. The reason for this is they are pretty cheap to begin with and do not vary greatly in capabilities by size, so there is no advantage to spending hours browsing around for one with has better specs for fewer bucks, etc. Presuming you don't spill coffee on it, a brick and mortar store will usually do a refund or exchange, no questions asked, within 7 days (at least most of them will in N.A., be sure to check). So if it turns out not to work properly, you can just bring it back and get another one. Also, stores tend to have much less selection than online retail, and that selection will be the most popular and commonplace items (which are more likely to have well tested linux drivers).


1. USB IDs are what the OS uses to identify a device and select an appropriate driver. Sometimes there are devices whose IDs aren't listed, but for which an existing driver will work if loaded manually.

  • 1
    Or go for the truly tried-and-true ones, such as the Edimax 7811Un. Cheap and works everywhere. From the OP's post I assume he/she is located in Romania, perhaps Amazon UK ships there, hence the UK link. – Phil B. Sep 22 '15 at 14:54
  • @PhilB. Yes, I'm in Romania. What I still don't understand is why isn't the other adapter working–from what I saw it's working for others. Anyway, the refunded me. The closest I got was to scan the the wifi networks while connected to a desktop computer, but not to raspberry pi. Thanks, goldilocks for good answer! – Ionică Bizău Sep 22 '15 at 14:57
  • 1
    No risk, no fun––I ordered it and arrived some minutes ago. Pretty happy. It's working fine. :) – Ionică Bizău Sep 28 '15 at 14:23
  • @IonicăBizău :) For posterity, have a look at lsusb for the ID and lsmod to see which driver is loaded (mt7601u or rtl8192cu -- the latter might be just 8192cu) and leave another comment. – goldilocks Sep 28 '15 at 15:25
  • @goldilocks I added it. Not sure which one is used. I recently did sudo rpi-update–I guess yesterday, giving the other adapter one more chance. :) – Ionică Bizău Sep 28 '15 at 17:18
1

I suggest a free driver USB wifi adapter for raspberry pi.it uses RTL8188UCS chip. I order a one from amazon on line,and works well.the links is http://www.amazon.com/dp/B014SP9FN0 .

0

I am running the 8192cu version of the Asus N10. I needed to disable power management by creating the file /etc/modprobe.d/8192cu.conf with the contents:

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

After reboot it was stable. Running on Raspberry Pi 2 and Raspberry B with jessie and kernel 4.1.15. Driver was included in the OS.

0

I'm using a Jessie Raspbian 4.1.19+ with that Asus N10 Nano / 0b05:17ba and it will work out of the box, but it seems the 8192cu precompiled driver in the distro might not support AES, so in my case it only worked to set router to TKIP explicitly.

My router was on Auto AES/TKIP choice, which worked perfectly fine while N10 was plugged in the PC, but on RPI it failed with an error in /var/log/syslog or /var/log/wpa-supplicant.log

"wlan0: Association request to the driver failed"

The official Realtek N10 driver is here http://www.asus.com/Networking/USBN10/HelpDesk_Download/ and can be used to build for RPI, but usually there are people on github who already integrated them ( just google the driver name and rpi - example result for this dongle is https://github.com/ksclarke/rtl8192cu )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.