I just ordered my raspberry pi 2 model B.
I am using a class 10 16Gb Sandisk SD card. I used Win32DiskImager to burn the pre compiled Disk image provided by Jasper.
I connected the HDMI cable of my TV to pi's HDMI port, connected keyboard to USB, and put the SD card into the slot.
When I used the 5V charger of my phone to power it ON, the red and green lights turn on but there is no display on the TV.

Please help.

EDIT 1: My config.txt looks like this

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#uncomment to overclock the arm. 700 MHz is the default.

# for more options see http://elinux.org/RPi_config.txt
  • It might be possible that jasper image is an old one and Rpi 2 didn't existed at that time. If that's the case, you need to boot it on Rpi 1, update it by sudo apt-get update && sudo apt-get upgrade and then boot it on Rpi 2. How to tell if it's an older image ? well, usually if you don't see random ACT blinking (green light), that should be probably it. Hope it helps. Sep 25, 2015 at 9:45
  • I dont have an Rpi 1. What to do? any other method? Sep 25, 2015 at 9:54
  • 1
    Start with the latest Raspbian and try doing installing jasper by method 3 as per mentioned in that link. Sep 25, 2015 at 10:45
  • akshaynagpal if it is not much trouble, can you please take a new image and post it here? this way we know it's a working image.
    – user46719
    May 18, 2016 at 13:54

3 Answers 3


If the green light flashes in a regular, repeating pattern, as dastaan points out, the problem may be that Jasper image does not have a Pi 2 kernel on it, which is certainly possible since they only mention the Pi B under "hardware".

However, in my experience that's not necessarily what happens with an A/B/+ kernel on a Pi 2; instead, it will load successfully and then fail at some point. This probably would include some output on the display and leave the green light off, but I have not tried it enough times to say that it will always fail the same way.

If the green light simply comes on and stays on, another possibility is that the hardware has not recognized the card at all, as this is what it will do with no card inserted. It could also be you have not completely clicked it into place.

The only way to test that is to try an image which is known to work (such as a recent Raspbian), and then if that does not work, the same thing with a different make/model of SD card.

You might also want to double check with a different display if possible, although I think the green light staying on is indicative of a more fundamental problem.


Don't know the "Jasper" image, but I had a similar issue with the 20150505 Raspbian image lately. Long story short: WinDisk imager was the culprit. I then flashed the 20150505 using my Linux machine (you know, the "dd ..." approach) and all worked fine. Maybe you can try the same with your "Jasper" image...

  • I flashed Raspbian using WinDisk Imager, and it worked fine. Oct 3, 2015 at 9:08
  • Yes, but what version? Up until the version 20150217, I used to use WinDiskImager too, with success. Only, since version 20150505, it didn't work for me anymore. The only successful way I could flash that version, was with Linux. Didn't investigate further as to why WinDiskImager was not working anymore for the latest Raspbian version, though... I've seen there's a new image out there using Debian Jessie as base, so I'll try again to flash that version with WinDiskImager and see if there's any change in success...
    – GeertVc
    Oct 4, 2015 at 16:27

Thanks for your inputs. I finally was able to run Jasper on Raspberry Pi 2 Mod B by bulding Jasper from scratch as described at http://jasperproject.github.io/documentation/installation/#manual-installation Following which the display and everything worked perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.