3

I'm running the RaspberryPi as a Server that is connected to the network over WiFi using the Edimax EW-7811UN Dongle. I configured the dongle according to the documentation, like

opening configfile

sudo nano /etc/modprobe.d/8192cu.conf

pasting

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

to disable all sorts of powersaving. But still: As soon as the WiFi router disables the WiFi connection the Dongle does not wake up any more. The connection can not be re-established.

If've already found a work-around (from the Raspberry Pi forums), to run this script as cronjob

#!/bin/bash
# check if a wlan0 if exists
if echo `/sbin/ifconfig` | grep -q $1; then
#check if there is IP Address
  if echo `/sbin/ifconfig $1` | grep -q "inet Adresse"; then
    exit 0
  fi
  /sbin/modprobe -r 8192cu
fi
/sbin/modprobe 8192cu
exit 0

But that doesn't smell like the clean solution I'm looking for. Does anybody else experience this issue and has a simpler solution?

Thanks in advance!

2

I am running the same wifi adapter on a RPi A+ running updated raspbian wheezy and do not experience those outages:

bob@raspi09:~% lsb_release -d
Description:    Debian GNU/Linux 7.8 (wheezy)
bob@raspi09:~% uname -a
Linux raspi09 4.1.6+ #810 PREEMPT Tue Aug 18 15:19:58 BST 2015 armv6l GNU/Linux

Here's my current /etc/modprobe.d/8192cu.conf:

# Disable power management
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0 rtw_ips_mode=1

I did have a very similar problem on an older Model B with the same adapter, but recent updates seem to have cleared up the problem. I had previously tried adding wireless-power off to /etc/networking/interfaces as discussed in this thread but encountered error messages, so abandoned that approach.

Is your RPi firmware up to date? (sudo apt-get update; sudo apt-get upgrade)

Also -- Just to be certain -- Is there any chance the RPi is connecting to another AP/router when your primary drops off? Can you get onto it to check ifconfig?

  • you might want to change that last question into a conditional statement like "It might be that your RPI firmware is not up to date, here is how you update the firmware ..... " – Phil B. Sep 25 '15 at 18:49
  • My RPi is up to date (Linux rpi 4.1.6+ #810 PREEMPT Tue Aug 18 15:19:58 BST 2015 armv6l), but I was missing the line rtw_ips_mode=1. I'll watch what happens next few days and mark your answer as correct when the connection is stable :) Thanks ! PS: RPi doesn't connect to another AP or router since ethernet is disconnected and only one WiFi password is given – Boern Sep 27 '15 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.