1

I'm trying to run wifi on my device. It has been working a week ago (so I believe it is not a hardware problem), but two things happened since then: I run apt-get upgrade on my raspberry and my internet provider installed at my apartment a new wifi-modem Cisco EPC3928.

My configuration is as follows.

# /etc/network/interfaces
auto lo
iface lo inet loopback

auto wlan0
allow-hotplug wlan0

wpa-ssid "my-network"
wpa-psk "passwrd"

I am getting IP from DHCP for a mere few seconds but it is lost very quickly (typically within 15 seconds, but I'm able to ping before it happens).

Any idea how to fix it? The only thing that looks suspicious to me is that my mask is router IP is 192.168.0.1. When I run sudo service networking restart, it connects to 192.168.0.1:67 But in /var/log/syslog I read (among other things):

DHCPRELEASE on wlan0 to 192.168.1.1 port 67
receive_packet failed on wlan0: Network is down

I really don't know where that 192.168.1.1 comes from.

I've tried also the solution wit wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf file but this didn't work for me; i'm getting error message that roam method works only in manual mode

  • I could be that another device on your network is using the same IP as your Pi, that happened to me a while back. – Patrick Cook Sep 26 '15 at 20:03
1

You have to enabled DHCP auto, not static IP address during every restart, that will solve the problem.

Example :

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

For DHCPv6 :

iface eth0 inet6 dhcp

Auto Configuration use auto:

iface eth0 inet6 auto
0

You have fiddled with too many things at once.

First get the router working with another computer THEN configure the Pi. See https://raspberrypi.stackexchange.com/a/36345/8697 for some hints.

  • My router works correctly with all other devices, 5 in total. All connections (including a PC) are wireless – tnorgd Sep 27 '15 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.