After an update a few months ago, the taskbar on the desktop disappeared and was replaced with a flashing grey bar.

I am running Jessie and am getting the following errors when running an update:

sub process returned with error code (1)
dependency problems
xserver not configured yet

and several other error messages relating to x-server components not being configured or present.

How do I sort this lot? I'd rather not reinstall because I've got a LAMP setup for local testing of websites and don't want to have to set it all up again.

I have looked at this page, but it is not relevant, looking in /etc/group pi is in the audio group.

  • Thanks for the answers which have eventually come in. I ended up reinstalling with a new image so I can't test anyone's answers. Unfortunately this means I can't mark anybody's answer as correct. Sorry. Apr 18, 2016 at 13:12

3 Answers 3


Try adding dtparam=audio=on to /boot/config.txt by fzinken

  • Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. While you may explain what steps to take you have not explained what your proposed fix does or why it should work. Your link is broken as well. Apr 14, 2016 at 13:36
  • +1,thanks my taskbar goes back. I've got this problem right after rpi-update.
    – SAMPro
    Jul 19, 2016 at 3:56
  • The link works fine! Oct 4, 2018 at 12:14

As per this page, it could in fact be an audio problem so I suggest instead:

sudo usermod -a -G audio <your_user>

At any rate, that's what worked for me.

  • Thanks for the suggestion. I eventually ended up reinstalling with a new image so I can't test your idea. I guess this means I can't mark your answer (or anybody else's) as correct. Sorry. Jan 7, 2016 at 6:03

I was having this problem with QEMU and Raspbian Wheezy (fully upgraded), and eventually solved removing the following block from ~/.config/lxpanel/LXDE-pi/panels/panel:

Plugin {
        Config {

Probably this is caused by an audio problem, because QEMU says:

dsound: Could not initialize DirectSoundCapture
dsound: Reason: No sound driver is available for use, or the given GUID is not a valid DirectSound device ID

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.