1

The file is as such:

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet static
    address 192.168.1.xxx
    netmask 255.255.255.0
    gateway 192.168.1.1
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

The pi is connecting to the network via the wlan connection, using a usb wifi adapter.

The pi is connected at the supplied static address and the previously assigned dhcp address. I've confirmed this via the router config page and via ping.

How can I correct this, and/or does it not matter?

ip addr returns the following under wlan0:

3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether zz:zz:zz:zz:zz:zz brd ff:ff:ff:ff:ff:ff
inet 192.168.1.xx2/24 brd 192.168.1.255 scope global wlan0
   valid_lft forever preferred_lft forever
inet 192.168.1.xx1/24 brd 192.168.1.255 scope global secondary wlan0
   valid_lft forever preferred_lft forever

z replacing the hw addr

  • Edit in the output from ip link. – goldilocks Oct 2 '15 at 11:25
  • 3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT qlen 1000 link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff – cfye14 Oct 2 '15 at 15:08
  • 'x' here standing in for hw addr – cfye14 Oct 2 '15 at 15:09
  • Sorry, I meant ip addr -- and edit it into your question, not comments. – goldilocks Oct 2 '15 at 15:21
  • If plausible, try rebooting your router, then the pi. – goldilocks Oct 2 '15 at 20:04
1

the other IP should be from /etc/init.d/dhcpcd. Try this and then reboot:

update-rc.d dhcpcd disable
  • This command will operate on a sysV init system (I can't say that it wil solve the OP's question) but is it applicable to systemd that the current Raspbian {and most other Linux distributions have now switched to, either, by default in Debian (and thus Raspian) or compulsorily on some others}? – SlySven Jan 21 '16 at 11:31
  • Both /etc/rc3.d/S01dhcpcd and systemd service dhcpcd.service are enabled in current (Nov 2015) raspbian. However, only /etc/rc3.d/S01dhcpcd is launched successfully on system startup, i.e. dhcpcd.service is failed to run anyway. – koyeung Jan 21 '16 at 11:37
  • so coming back to this after a few months, I changed the static IP and the problem has gone away for now. Will monitor. – cfye14 Jan 21 '16 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.