3

2 days ago I've setup a Raspberry Pi 2 as a Mopidy player. It worked fine until today. I wanted to re enable the radio stream but I could neither connect via MPD nor the browser nor SSH (from 3 different devices). I tried to directly access the Pi with Keyboard and mouse, which worked. From there I was able to reach the mopidy server with localhost:6680 and the radio worked, which means I am connected to the internet, and it works.

After pinging my computer from the raspi2 I could connect again from the computer. But I was unable to ping other devices in my network because it showed an error message: "Destination host Unreachable".

Then I rebooted the raspi2 and I again am unable to access the raspi2 via ssh, but I am able to ssh to it with a raspi1 model B after pinging my computer again I am again able to ssh from my computer. A weired thing here is though, that I only can ping the raspi1 and my computer but nothing else.

The Pi is connected via WiFi to the router

Is there any solution to my problem?

EDIT:

Today at 11:00 AM I tried again to connect to the pi via phone, which didn't work. 20 Minutes later it worked and now an hour later it still works...

But for future issues I would still want a faster solution to this problem other than waiting a night.

1

Networking issues are frequently due to the RPi's power supply having insufficient current available. During boots up, the RPi requires more power than during normal operation. This additional power draw causes a dip in output voltage as seen by the RPi which in turn causes unreliable operation of the RPi which often manifests with drivers loading during boot up to not work properly. The network drivers seem particularly prone to this phenomenon and usually fail to get a DHCP address, for example.

Try a different power source for your RPi. Even if the current source appears to have a high rating like 2A, it may not be able to handle the inrush current when the RPi is sparking up all its peripherals during boot up. Several times I've cured other people's networking issues by simply using a different power supply.

Alternatively, try a power USB hub and putting the WiFi adapter in the external powered USB hub - this will eliminate that power load from the RPi. This is good troubleshooting practice with networking issues with the RPi.

  • Hello. Your post has been automatically flagged as an duplicate answer - a verbatim copy of another post of yours. Please note that copying and pasting the same answer for different questions is not the correct thing to do. as it indicates that both questions are actually dupes - and should be flagged as such. If that is not the case, please consider adapting the answer to each specific question. Thanks. – Ghanima Feb 7 '16 at 20:54
  • The two questions are completely different but the proposed solution is the same. To placate the system, I've tweaked the wording for this one. – BartmanEH Feb 7 '16 at 20:57
  • Then they should not be closed as dupe. That's fine. You might still want to consider if the answers could be tailored to address the specific needs that each question has outlined. If it already does, all the better. I just want to make you aware of above mentioned guideline. – Ghanima Feb 7 '16 at 21:03
  • It was a 2A power supply, so that should be enough I think – szoszk Feb 8 '16 at 21:17
  • I embellished my answer with some further thoughts and suggestions on this. I always focus on power supply first especially since it's relatively easy to try other power sources. – BartmanEH Feb 8 '16 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.