0

I managed to get this working on a previous kernel by downloading the driver using the following commands:

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20150406.tar.gz
tar -zxvf 8188eu-20150406.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.18.11+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.18.11+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a
sudo reboot

However, since updating the kernel to 4.1.8+, I can't seem to get the thing to work using the same procedure. I'm now trying to use this driver:

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20150929.tar.gz

but can't get it to work my network config files remain the same

I found that this file:

'/etc/modprobe.d/8188eu.conf'

contained the line:

blacklist r8188eu

Commenting that line out had no effect.

lsusb returns the following:

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp.

('Realtek Semiconductor Corp' is the device in question) And lsmod shows the system is aware of the driver:

CODE: SELECT ALL 8188eu 933436 0

But attempting to restart the network with

sudo /etc/init.d/networking restart

Returns

 Running /etc/init.d/networking restart is deprecated because it may not r[warnble some interfaces ... (warning).
[....] Reconfiguring network interfaces...wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
ifup: interface eth0 already configured

I tried downloading what I think is the source for this driver:

 https://github.com/Red54/linux-shumeipai2.git

But couldn't figure out how to build it - 'build.sh' gives the following message:

build.sh - Top level build scritps                                  
Valid Options:                                                      
  -h  Show help message                                             
  -p <platform> platform, e.g. sun4i, sun4i-lite, sun4i_crane       
  -m <module> module                                                

(goodling 'sun4i' reveals it's something to do with a system-on-a-chip thing - is that the guts of the TPLink chip? I'm not sure which one to build.

Obviously this is all a bit of a pain and I'd appreciate it if anybody could help. Also, can anybody tell me why my particular brand of wifi dongle doesn't 'just work'? Should I avoid this brand in the future if I want to have better compatibility on pi (ubuntu mate works out of the box, not sure why raspbian does not)

  • Kernel modules must be built against the same source as the kernel itself; i.e., if you are using 4.1.8+, you need to build the module with the 4.1.8+ source. – goldilocks Oct 3 '15 at 17:02
  • Check on the Raspberry Pi forums for the updated driver for new kernels. You'll need to update it every time the kernel is updated, at least until it ships with it built in. I've posted the link in other threads. Can't link now, on the road. – bobstro Oct 3 '15 at 18:14
1

try sudo ifdown wlan0 and sudo ifup wlan0 instead of sudo /etc/init.d/networking restart

that repository looks like the complete Linux source, the drivers are in tree/sunxi-3.0/drivers/net/wireless/rtl8188eu

this rpi forum post link might be of some use

https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=29752

  • Thanks for the reply, ifdown and ifup return a similar result: wpa_supplicant: /sbin/wpa_supplicant daemon failed to start run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1 I'd reached the same conclusion with the 'driver source'. Seemed a tad hefty when downloading. Quite possibly there's a driver in there somewhere but I want to compile a module, not whole linux kernel (trying to keep it simple, failing) – Luther Oct 3 '15 at 16:14
  • That link mentions some V1/V2 problems with the TPLINK dongles - however, I did have this working with a module downloaded from the links I had but once I updated the kernel, nothing worked and new versions from that site also failed to work. – Luther Oct 3 '15 at 16:22
  • Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Steve Robillard Oct 4 '15 at 2:09
0

I was having problems just like you after upgrading to kernel 4.1.19, but this link helped me:

Drivers for TL-WN725N V2 - 3.6.11+ -> 4.1.xx+

It contains the updated drivers for TP-Link wifi dongles.

Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.