1

I have the eleduino 7" touchscreen. The image with pre-installed driver they ship it with disable the GPIO pins. Touchscreen works in Kivy though. I was helped here by TMWILSON26 who referred me to the custom drivers of derekhe.

Did a fresh install of wheezy. Installed the custom drivers and the touch screen works. Installed kivy without any problems. It works with all the python games in X, it works everywhere except in any Kivy app. Doesn't matter if I run the kivy app with 'sudo' or not. It also doesn't matter if I don't run 'startx'.

Added the 3 lines:

mouse = mouse
mtdev_%(name)s = probesysfs,provider=mtdev
hid_%(name)s = probesysfs,provider=hidinput

to the .kivy/config.ini

still doesn't work. Help! :-)

0

Well Kivy on the Rpi does work. Clearly there is a configuration problem so I recommend that you get another SD card and download KivyPie from here: http://kivypie.mitako.eu/

There are some test programs and they ran for me right out of the box. No startx is required.

Assuming it runs for you then check the config.ini file in ~/.kivi and you might find the settings that are different from your current set-up.

  • Tried this. Problem is that eleduino doesn't supply drivers. So when I run Kivipie, the touchscreen doesn't work because it isn't installed. Installing the custom drivers makes the touchscreen work it work in pygame apps but not in Kivy. DEREKHE says his custom drivers simply emulate a mouse. Weird thing is, when I enable the mouse in a kivy app, an actual mouse works, but the touchscreen still doesn't. – jojonl Nov 4 '15 at 6:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.