1

I was trying to connect Raspberry Pi 2 to my computer (Ubuntu) using USB-to-Serial.

I have exactly followed the tutorial on the internet.

I can find the usb device, and I am in the group dialout:

cliu@cliu-ubuntu:~$ ls -l /dev/ttyUSB0 
crw-rw---- 1 root dialout 188, 0 Oct  6 20:31 /dev/ttyUSB0
cliu@cliu-ubuntu:~$ sudo adduser cliu dialout
The user `cliu' is already a member of `dialout'.

And the driver is correct.

cliu@cliu-ubuntu:~$ lsusb
Bus 004 Device 002: ID 8087:8000 Intel Corp. 
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 8087:8008 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 04ca:7034 Lite-On Technology Corp. 
Bus 001 Device 038: ID 05ac:12a8 Apple, Inc. 
Bus 001 Device 041: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 004: ID 8087:07dc Intel Corp. 
Bus 001 Device 040: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And I am sure that the wire connections to GND, TX and RX are correct.

enter image description here

But after use Putty to open the prompt, there is nothing but black window screen. I have also pressed [Enter] after open Putty. Putty is opened with sudo. And I am using 115200 rate.

Have to mention that: my Pi is completely working with external display via HDMI, and is working through ssh and VNC viewer as well. I just would like to controls and use it from my computer when there is no external display or no internet connection.

EDIT:

I have checked my PC settings and the USB-to-Serial as well using other RPi and found that everything is correct. The problem is from the RPi itself. But I have checked everything possible configurations that I could think of or find online, it was not working.

I reinstalled the Raspbian. Then it's working.

Possible problems: when first installing the system, I also selected the "Boot to scratch " and "500 MB for boot settings". These may lead to different configurations. But I'm not sure. Good luck to you all.

  • What tutorial are you following? We will need to see pictures of the connections? Have you tried swapping the TX and RX wires? Please edit your question and include these details. – Steve Robillard Oct 6 '15 at 19:22
  • @SteveRobillard I have edited my questions. and indeed, I have tried swap tx and rx. – fluency03 Oct 6 '15 at 19:35
  • Are you expecting a login message from the Pi? Perhaps the login ability has been disabled with raspi-config? Are you using 115200 for the baud rate? – joan Oct 6 '15 at 19:57
-1

To debug this, I'd suggest:

  • Verify that loopback works on the USB serial device. To do so, you can physically wire TX/RX together (green and white wires of the cable you referenced). Leave the 5V and GND unconnected:

    echo blah > /dev/ttyUSB0

    and then:

    cat /dev/ttyUSB0

    Note, the actual name of the device may be different than ttyUSB0. By default, you'll likely need to login as root. It may also be that you need to also turn off "echo" for this to work - you can do so with stty -F /dev/ttyUSB0 -echo. You can just use Putty as well. Physically disconnecting TX/RX should cause the loopback test above to fail.

  • You can do the same test on the Raspberry Pi to verify that loopback works there (GPIO pins 14/15), with device /dev/ttyAMA0. Note: Raspbian, by default has a serial console on that port - you can find more info on shutting that down if you search for ttyAMA0 here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.