2

I suddenly ran into this problem. My default OMXPlayer is not exiting ("hanging") after playing a .mp3 from the command line. The only way to exit is Ctrl Z, so I can't use any sort of loop function for a playlist. My songs are played from a networked NAS directory using NFS mount. I tried to un- and remount again, hide error messages ( > dev/null) and to set the timeout to 1 second (--timeout) without success.

The setup and command line worked perfectly a few days ago. Now I can't even get OMXPlayer to exit normally even after only trying to play one song:

omxplayer -o local --timeout 1 "/mnt/song.mp3"

Any ideas what can be wrong?

1
  • 1
    Same thing happens with me. I think it's just the way omxplayer works. If you want, since it's open source, you can edit the code yourself.
    – Kachamenus
    Oct 8, 2015 at 16:27

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.