3

So I have a VNC server running on my windows laptop and I want to connect it to my Raspberry Pi in full-screen. I've been using:

xtightvncviewer -fullscreen

but all I get is thisenter image description here

Is there any way I can force scale to always fill my display?

2

The TightVNC viewer for Linux does not support scaling. You have to use a different viewer. You can use the forked-off ssvnc, which viewer has a scaling option.

http://www.karlrunge.com/x11vnc/ssvnc.html

  • I can't get the scaling option to work. Do you have a working example command? I've tried ssvnc -scale fit Vnc://1.2.3.4:5900. – wullxz May 26 '17 at 9:47
  • 1
    Try SSVNC_SCALE=1.4 ssvnc 1.2.3.4:5900. It seem both the -scale option and fit is somewhat tricky to use. – Janka May 26 '17 at 12:45
  • I noticed there is another binary called ssvncviewer which doesn't spawn that annoying GUI and also accepts the -scale option although fit/auto are somewhat misbehaving. – wullxz May 26 '17 at 13:01
  • Try ssvncviewer -scale $(xrandr|grep '*'|sed 's/^ *//'|cut -d' ' -f1|head -n1) localhost:5900 – Janka May 26 '17 at 13:16
1

Yes. It is very simple to do this.

When running the command to start the VNC server on your RPi, add the parameter for resolution.

EX:

If the resolution of your screen is 1920x1080, like mine is, then run:

vncserver :0 -geometry 1920x1080 -depth 24

This will start a VNC server at [YOUR RPI IP ADDRESS]:0

You can replace 1920 and 1080 with your screen's resolution.

  • Alright sweet but how can I do the same thing on my windows, my raspberry pi is just the client – Nathan O Oct 17 '15 at 16:01
1

You can try steps given in this thread. Adding the code here, for brevity. SSH into your Pi and enter the following:

sudo /boot/config.txt /boot/config.txt.bak
sudo nano /boot/config.txt

With the first command you are creating a backup of the original configuration. You can revert back to this if something malfunctions due to changes in the future. Then open nano, which is an editor and next make the following changes:

...
# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=16
...

After making the above changes you force your Pi to display in HDMI mode.

Note:

  1. You need to remove "#" from the corresponding line to uncomment it
  2. Nano is simple to use - just like notepad in Windows
  3. Do save your file upon exit
  4. reboot system using sudo shutdown -r now

It worked perfectly for me, I hope it goes well for you also.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.