10

I have a Raspberry Pi Model 2 running the newest version of Raspbian Jessie. My Pi is connected to the internet using an Edimax Wireless adapter, and I can download and browse the internet just fine. However any time I try to ping the Pi I get

Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
ping: sendto: No route to host
Request timeout for icmp_seq 4
ping: sendto: Host is down

Anytime I try to SSH to the Pi it also times out. I have tried forwarding ports on my router, assigning static IP Addresses on the Pi and on my router, reinstalling Raspbian, etc. Any help would be greatly appreciated. Thanks!

Update: I now have a Raspberry Pi model 3 (with built in Bluetooth and WiFi). After installing the newest version of Jessie and connecting to my home network I am faced with the same problem as stated above. The only new occurrence is that when I ping my routers' IP address I get a normal response, but from any other network device I get the errors stated above. Any advice would be great!

  • can you ping your RPi or start a ssh-session if you are connected to the same network? – DJCrashdummy Oct 10 '15 at 16:10
  • No I cannot. Being wired to the network, or on wireless it does not work unfortunately. – Sullivan Prellwitz Oct 10 '15 at 20:25
  • I have the same situation. Tested Jessie Lite and Full on both the same. I can SSH and ping from another PI but not from Windows 10. From the same Windows 10 I can SSH and ping the other PI running the previous kernel not the 4.1. – user39404 Jan 6 '16 at 18:11
  • I'm having the same issue. I noticed that if I ping another host on the local network from the pi, the issue is resolved and I'm able to reach the pi from other computers on the local network. I suspect the pi is not properly responding to ARP requests or something and so it never makes it into the router's routing table. I setup a cron job to ping another local IP regularly and it seems to have resolved the issue for me. – Kelly Norton Mar 31 '16 at 12:23
  • I have a Pi 3 and getting this same thing... none of the answers for earlier version seem to have any effect. Hoping someone figures it out. – RiddlerDev Jun 22 '16 at 19:25
1

Double check your IP Address, for one thing. use ifconfig on Mac/Linux and ipconfig on Windows to check where your router's page is. Enter the IP address into your web browser, and look on the list of connected devices on there.

If it's not there, make sure that your computer and Pi are on the same WiFi. If your computer's on Ethernet, connect it to the same WiFi just to be sure.

Also, type raspi-config, then make sure that ssh is enabled.

  • Already done, tried it on Ethernet and WiFi, both didn't work unfortunately, but that you for the suggestion – Sullivan Prellwitz Oct 10 '15 at 16:41
  • You're very welcome. I'll edit in another suggestion I thought of... – Kachamenus Oct 10 '15 at 17:11
  • So I have SSH enabled, and just to be sure I checked to make sure the server was running. Which it is. So I'm very confused why it isn't working. – Sullivan Prellwitz Oct 10 '15 at 20:24
  • if you aren't already working within the same LAN, for troubleshooting please do so! -- make sure that ssh is enabled AND working (maybe you have to restart the RPi) and then check with LC_ALL=C ifconfig | grep -i 'inet addr' the correct ip-address of your RPi... – DJCrashdummy Oct 12 '15 at 7:07
1

I had identical problem. There was a bad interaction between my raspberry and the router.

If your router supports APSD / WMM (look on the wireless configuration page), turn it off. On my tomato router, I had to turn it off separately for both bands.

1

If the Raspberry Pi, for whatever reason, doesn't send any network traffic for a while, you may run into the problem of MAC table timeout (aka CAM aging). Network switches have a lookup table keeping track of what network interface is connected to which MAC address(es). It's like an ARP table, but for the Ethernet layer. Whenever the switch sees a packet from a given MAC address, it refreshes its table of which interface that address is on. But there is a timeout period (default 5 minutes) after which it forgets. If a packet then arrives at the switch for that address, it has no idea which interface to send it to. This could lead to those "No route to host" or "Host is down" messages.

I've seen this on Ethernet switches, but I think it applies to WiFi also: a WiFi router needs to know if it should send a packet to one of its hardwired LAN interfaces, or via its 2.4 GHz radio, or via 5 GHz.

High end switches will send ("flood") the packet out all interfaces. Some consumer switches just drop the packet.

This is almost never a problem for most operating systems like Windows, because they are so chatty: they are always sending out network traffic of some sort, so their entry in the switch stays refreshed.

If you can't connect to the Pi from another computer on the network, try logging onto the Pi locally. If you then do anything which causes even a single network packet to be sent, the problem should be resolved for another 5 minutes.

This could seem like a very inconsistent problem, since the Pi may spontaneously send network traffic occasionally, but it may not always be within 5 minutes. So, the problem could come and go. Your configuration may vary.

So, one solution would be to run something in the background on the Pi that sends a packet out, say, every four minutes. Maybe a single ping as a cron job.

0

The issue appears to be that the WIFI dongle is not responding to ARP requests in a timely manner (perhaps due to power issues). The following thread contains a number of options that resolve the issue.

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=33369

Some folks in the thread claim that turning off power management on the WIFI dongle works for them. It did not work for me. I needed a way to push out ARP entries since I couldn't rely on my raspberry pi to do it appropriately.

So I went with a hacky approach where I ping every host on the subnet every few minutes to force an ARP table entry.

crontab -e

And add an entry like this (assuming your subnet is 10.0.1.0/24)

0/10 * * * * fping -qg 10.0.1.0/24
  • The issue seems to be more network related because with the Pi 3 I am using built in WiFi. Not a dongle. – Sullivan Prellwitz Apr 13 '16 at 1:33
0

https://www.raspberrypi.org/forums/viewtopic.php?f=27&t=15814

Please refer the link above. it works with my RP

  • 2
    Link only answers are not desirable – Darth Vader Apr 23 '16 at 10:24
  • Please take the tour and visit the helpcenter. Whilst this may theoretically answer the question, it is preferable to include the essential parts of the answer here, and provide the link for reference. In fact we're enforcing this policy: please edit so that the answer stands on its own should the link break in the future. If it is not edited within 48 hours it will be converted to Community Wiki. – Ghanima Dec 15 '16 at 14:34
0

check the router settings you need to turn off AP isolate feature or something like that! with this feature, clients connected to the Wi-Fi network will be blocked from communicating with other devices on the local network but they can access the internet!

protected by Community Jan 16 '17 at 3:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.