0

I did a quick search and found someone who had a similar issue to this but was ahead of me so I'm not sure how to set this up? I have my pi connected to my router with a 4 bay nas drive connected to the pi via USB. When I turn on the pi and type startx I have to add the drives manually each time, which is fine if I keep the pi running 24/7. I have installed netatalk and the home directory shows up on my shared network, but I can't seem to access the media folder. I know I'm supposed to type: sudo nano /etc/netatalk/AppleVolumes.default and edit the drive I want to mount but I'm not sure what aprt to edit and when I do change a line down at the bottom which relates to home directory I can no longer connect to the pi? Any help is appreciated.

  • 1
    Your question is unclear. Are you trying to connect to or from the Pi? Tell us WHAT YOU DO to " add the drives". AppleVolumes.default controls which directories the Pi exposes. – Milliways Oct 11 '15 at 23:13
  • I apologize. I am trying to connect from a Mac to the Pi with the drives attached to it. I am trying to transfer files from my Mac to the usb drive rather than the pi itself. When I "add them manually" what I mean is File Manager pops up and asks me what to do with these drives it has found connected to the Pi. I then click ok to make them attach I assume. The media folder is where my external drives are located. Hopefully this is a bit clearer. – Deejaydoubleyou Oct 12 '15 at 4:52
0

You are asking 2 questions:- 1. How to automount network drives 2. How to connect to a mounted drive on th Pi using netatalk.

A suggestion for the 2nd is to add lines at the end of /etc/netatalk/AppleVolumes.default. Mine contains the line /etc "$hRoot" which lets Appletalk mount the directory /etc as "$hRoot" where the $h is replaced by the Pi Hostname (default raspberrypi). You could use /media/MountPoint for each drive or just /media for all mounted volumes.

# The line below sets some DEFAULT, starting with Netatalk 2.1.

:DEFAULT: options:upriv,usedots

# By default all users have access to their home directories.
~/          $hHome

:PIROOT: options:upriv,usedots,ro
/etc            "$hRoot"
# End of File

I cannot give a definitive answer for the 1st, as I don't do this, but you normally would add an entry to /etc/fstab. If you run mount after you have manually mounted a drive this will give an idea of the settings. Post a new question about this if you need further help.

  • Thank you for the info. I will try this out. I am not so concerned over #1. It was more to do with the second question. – Deejaydoubleyou Oct 12 '15 at 23:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.