1

I have looked at all of the questions on here and other sites and done what they've said and nothing is working. My wifi used to work and now it doesn't nothing has changed with my network, I made sure. I wanted it to have a static IP of 172.16.0.16 but right now I don't really care about the IP, I just want it to work. Here are my files:

/etc/network/interfaces:

auto lo
iface lo inet loopback
iface eth0 inet dhcp
iface default inet dhcp
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

/etc/wpa_supplicant/wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid="mystupidnetwork"
    scan_ssid=1
    psk="mystupidpassword"
    key_mgmt=WPA-PSK
    priority=15
}

I get no errors or anything when booting, it just never even attempts to start /etc/network/interfaces. The only thin it mentions is Network Plugging Daemon...skip eth0...done. that is the only thing in my entire boot sequence that says anything about network or internet or anything.

  • Any question/answer before May (and many after) is incorrect. Raspbian has changed. See raspberrypi.org/documentation/configuration/wireless/README.md I doubt that what you have would ever have worked, but it certainly won't work unless you have an old version. – Milliways Oct 11 '15 at 23:04
  • @Milliways I used that tutorial to set up wifi originally. Which is what had worked for a long time. – Patrick Cook Oct 11 '15 at 23:14
  • IF you used this tutorial you could not possibly have the config files you listed. – Milliways Oct 11 '15 at 23:16
  • @Milliways That's the one I used when it was working previously, I changed them based on other tutorials in an attempt to fix it. – Patrick Cook Oct 11 '15 at 23:50
2

This applies to Raspbian Wheezy prior to 2015-05-05 for later (and Jessie) See How do I set up networking/WiFi/Static IP

If you are running a recent Raspbian /etc/network/interfaces should be as below. (If the Foundation had setup dhchcd as the author intended this would not be needed).

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
  • This did not work. Ethernet works fine, as it has been, but Wi-Fi does not. I checked my Wi-Fi card on my laptop and it works fine, so I'm guessing that's not the problem. – Patrick Cook Oct 11 '15 at 23:59
  • ok, I formatted a new SD card and it is working fine now.. – Patrick Cook Oct 12 '15 at 1:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.