1

I'm trying to change my default audio device. However, alsa-base.conf just isn't in that folder. Is there any other way to do this?

I am running Raspbian.

2

You can simply create this file, make sure it is owned root, group root and set mode 0644 (owner read/write, group and other read). You can then add whatever options lines you want. E.g.:

su root
cd /etc/modprobe.d
echo "options foo=bar" > alsa-base.conf

Should work, presuming you have a password set up for root.

  • Use sudo -i rather rthan su on Raspbian – M Noit Nov 13 '15 at 13:25
  • @MNoit Why? As far as I'm aware, one is no more restrictive than the other. – goldilocks Nov 13 '15 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.