I am using openelec.tv for my raspberry pi and it runs fine, however no addons are showing up when I try download them.

I have run xbmc on my own computer and the addons appear so I am not sure what I can do to fix.

  • 2
    Could it be that the addons are not yet ported to ARM and so aren't supported on the Pi?
    – Jivings
    Jun 16 '12 at 22:41
  • It may be due to the addon/plugin authors not having ported their scripts to ARM yet? Do you have an internet connection from the Pi to the rest of the world? If there isn't any internet connection then it wouldn't be able to connect to the addon server. According to this thread you should, at the very least, see the dcron addon. Are you using a prebuilt openelec/raspbmc image, or did you add it to Fedora/Debian Squeeze?
    – darryn.ten
    Jun 26 '12 at 11:22

When I did a test run of this on OpenElec XBMC I noticed the same issue.

I was trying to get it to run with a WiFi USB (supported or unsupported I could not get it to work)

By default XBMC will ALWAYS USE LAN even if you set-up up WiFi. Make sure your LAN gives out DHCP and that the default gateway is set.

After I plugged in my LAN cable it took about 10~15 minutes and all the add-ons started to show up. For the first time something runs in the background each add-on one by one to make sure they are stable or if new versions are available. During the initial 10~15 minutes I got message like "plugin-b.x is no longer supported - Would you like to remove it from the plugins source" I pressed no (but in the list it marked as unsupported/broken)

After that I could download any plugin I wanted. (except iPLayer for BBC which I really really really wanted.. damn :( but most of the others are there. The GUI is slow compared to PC but it still is very impressive as it plays Xvid, DivX out of the box! about 15fps on ModelB and Full 30fps on H264! nice)

I read the is a secret console available for debugging.. try and read up about that. It might be that even you have DHPC the XBMC cannot find its way to the internet for one or another reason like DNS, GateWay, OLD IP.. etc


Choose Programs, then your OpenElec settings. Under Network, use WLAN, then wlan0 and put in your settings. Under Network 2, choose NONE for the second adapter. This will force your XBMC OpenElec build to use WiFi only.

  • Hey Jonathan, This seems a good answer but can you explain what you are doing a bit, and maybe add some line breaks in? Sep 22 '12 at 11:25

Try using Samba if you have a Mac, or ssh. That worked for me. BTW, did you "install from the zip file" or just "install addons"? Also, you can try the Ethernet connection rather than using WiFi adapter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.