7

I am building Raspberry Pi B+ VPN using OpenVPN. Following this tutorial http://readwrite.com/2014/04/10/raspberry-pi-vpn-tutorial-server-secure-web-browsing and this tutorial http://www.bbc.com/news/technology-33548728 I need to do

cp -r /usr/share/doc/openvpn/examples/easy-rsa/2.0 /etc/openvpn/easy-rsa 

However, when I run this I get:

cp: cannot stat ‘/usr/share/doc/openvpn/examples/easy-rsa/2.0’: No such file or directory

I have done:

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install openvpn

Everything is up to date. Any thoughts?

9
  • Well, is the folder there? What do you get from: ls /usr/share/doc/openvpn/examples/easy-rsa/ Oct 17, 2015 at 17:20
  • I get the message:"No such file or directory"". Thank you for your speedy help, I am really unsure what to do here.
    – user33594
    Oct 17, 2015 at 17:21
  • work your way upwards, is there anything if you do ls /usr/share/doc/openvpn/? Oct 17, 2015 at 18:08
  • Yes, I have that file, I see several words of red and white and blue: in blue, examples; in red, COPYING.gz and others; in white, PORTS, README, and others. Many thanks, what next?
    – user33594
    Oct 17, 2015 at 18:15
  • OK, so that means that you have a folder called /usr/share/doc/openvpn/ so probably your command sudo apt-get install openvpn did not failed completely. The command ls is used to list files and folders. You do have a examples folder. What's in there? What do you get if you type ls /usr/share/doc/openvpn/examples ? Oct 17, 2015 at 18:21

4 Answers 4

12

You are probably following instructions for Debian Wheezy while running Jessie.

On Jessie and above:

  1. apt-get install easy-rsa

  2. cp -R /usr/share/easy-rsa/* /etc/openvpn/easy-rsa/

I found that (1) is not necessary since it is now a dependency of OpenVPN.

See https://wiki.debian.org/OpenVPN#OpenVPN_Overview

2

I ran into the same problem today while setting up my own VPN. I finally got it working by following the instructions on this site. Basically, the only two commands I needed were:

sudo apt-get install easy-rsa
sudo make-cadir /etc/openvpn/easy-rsa

After that, all the required folders and files were right where the tutorial told me.

I know, the question is not the newest, but maybe I could help you or others that have trouble setting up OpenVPN, anyway.

2

Do

cp -r /usr/share/easy-rsa /etc/openvpn/easy-rsa

They changed the locations with upgrades.

1
  • this should be marked as the correct answer Dec 30, 2016 at 17:18
-2

I had the exact same problem. If you grep for easy-rsa, you'll find a .deb package in /var/cache/apt/archives. Try manually installing it with dpkg -i /path/to/package.

3
  • Why did this get a thumbs down, does it not work? Will try ASAP.
    – user33594
    Oct 20, 2015 at 21:58
  • Not sure. This was the only way I found to solve this issue. Did it work out @ThomasShera? Nov 4, 2015 at 21:14
  • I unfortunately haven't had chance to test this yet, although I later diagnosed the problem was a spotty Ethernet connection. Thanks again for the help, really appreciate it.
    – user33594
    Nov 6, 2015 at 0:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy