When I go to download Google Chrome from http://www.google.com/chrome in Midori on the Raspberry Pi , I am presented with a modal dialogue box,

Please select your download package:

  • 32 bit .deb (For Debian/Ubuntu)
  • 64 bit .deb (For Debian/Ubuntu)
  • 32 bit .rpm (For Fedora/openSUSE)
  • 64 bit .rpm (For Fedora/openSUSE)

Not Debian/Ubuntu or Fedora/openSUSE? There may be a community-supported version for your distribution here.

Is it possible to install Google Chrome on the Raspberry Pi? How would I go about it?

  • 1
    Chromium binaries are now available.
    – Jivings
    Commented Jul 19, 2012 at 20:37
  • I downloaded Noob today and it had Chromium installed built in.
    – user431
    Commented Oct 29, 2016 at 12:45

9 Answers 9


You can't install Google Chrome, but you can install Chromium. As other people have posted, Chromium is the code base out of which Google Chrome is compiled. Chromium is an open-source version of this browser. Simply type the following.


$ sudo apt-get install chromium-browser

If you receive any errors running this command, try running

$ sudo apt-get update

and then rerun the first command again.


$ sudo pacman -S chromium
  • 2
    This "just worked". Tested on Debian. Shortcut appears in the "Internet" folder in the programs menu. Commented Jun 19, 2012 at 22:00
  • 3
    @Scoop "chromium-browser" is the old name for the package. Since Wheezy, it is a dummy package to install chromium. See packages.debian.org/search?keywords=chromium
    – Lekensteyn
    Commented May 8, 2013 at 8:42
  • 7
    Please Chromium does not support HTML5 video DRM and so cannot be used for netflix etc. Just use Chromium is not necessarily a solution for people.
    – trampster
    Commented Oct 14, 2015 at 1:42
  • 2
    As of today, this is not working on my Pi 3. I get the following error: Package chromium is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: chromium-inspector chromium-bsu
    – Ryan
    Commented Jul 20, 2016 at 20:56
  • 4
    sudo apt-get install chromium doesn't work anymore; you must use sudo apt-get install chromium-browser instead. Commented Dec 5, 2016 at 5:07

As far as I know Google does not (yet) distribute Chrome binaries for Linux/ARM. (The only ARM binaries are for Android and these will not be compatible.)

You might be able to cross-compile Chromium for Linux/armel (I have not tried but I am willing to bet that the RasPi itself is not powerful enough to compile it.)

Also keep in mind that if you were able to install it, you may be disappointed with its performance as it is designed for somewhat more powerful machines.

  • 1
    I'm going to try X-compiling this evening. I shall let you know.
    – Jivings
    Commented Jun 17, 2012 at 12:17
  • 1
    The Chromium available through apt-get is quite usable. Note it does not support Youtube video. Commented Aug 1, 2012 at 22:25
  • @ThorbjørnRavnAndersen is there any way to get video support for just mp4 or webm in chrome?
    – Scoop
    Commented Jan 6, 2013 at 0:35
  • I do not know. Note that the Chromium build is not the full Chrome browser as distributed by Google. Given the amount of attention to the Pi I would say that you just need to wait a while longer. Commented Jan 6, 2013 at 9:27

Note that apt-get gives you a very old version of Chromium (v6). Hexxeh has a much newer build (v22):

  • 2
    v22 Now installs from api-get and works well
    – Adam
    Commented Mar 29, 2013 at 0:21

After finding out that Chromium is stuck at version 22 (current version is 31) I decided to switch to Firefox ie Iceweasel browser on Raspbian because it is kept updated.

  • 2
    As of February 2015, Chromium is still stuck at 22. Iceweasel is probably your best option.
    – aalaap
    Commented Feb 12, 2015 at 14:04
  • 4
    If you have Raspberry Pi 2 and want latest version of Chromium you can update Raspbian from Wheezy (Debian 7.0) to Jessie (Debian 8.0) and then have all upto date packages, including Chromium and Iceweasel (Firefox).
    – valentt
    Commented Feb 23, 2015 at 15:58
  • How did you switch to Jessie (Debian 8)?
    – zabumba
    Commented Jun 4, 2015 at 14:56
  • 2
    Alright found the answer HERE
    – zabumba
    Commented Jun 4, 2015 at 14:59
  • 'sudo apt-get install iceweasel ' Commented Jul 14, 2015 at 10:05

Chromium is working fine and get reasonable performance on my Raspberry Pi. Better than Midori.

sudo apt-get install chromium
  • Chromium is really faster than Midori? Chrome was often a huge memory-hog that bogs down the system in my experience.
    – NoBugs
    Commented Aug 11, 2016 at 6:20

Open Source Chromium is really good alternative for Google Chrome. But sometimes it's needed original Google Chrome. For example, you can't watch video with Netflix or Amazon prime with Chromium because it lack a couple of libraries.

You can install original x86 Google Chrome with help of ExaGear Desktop.

  1. Install ExaGear Desktop (note that ExaGear isn't free and you have to obtain the license)

    tar -xvzpf exagear-desktop-rpi2.tar.gz
    sudo ./install-exagear.sh
  2. Run ExaGear Desktop

  3. Download Google Chrome

    wget http://mirror.retrosnub.co.uk/apt/google/pool/main/g/google-chrome-stable/google-chrome-stable_48.0.2564.116-1_i386.deb
  4. Install Google Chrome

    sudo dpkg -i google-chrome-stable_48.0.2564.116-1_i386.deb
  5. Now you can run Google Chrome from Start Menu

Running Google Chrome on Raspberry Pi

Based on this post.


This works great.

sudo apt-get install chromium
  • 4
    This doesn't work on RPi2 - Jessie
    – JohnAllen
    Commented Jan 7, 2016 at 2:44

Because the question is already answered, I will tell you something else.

If you dont use the new Pi2, I really recommend you using a different browser, like midori. Simply because things will run smoother in midori/every other lightweight browser that with chrome/-ium.

  • 1
    In fact if you don't use the new Pi2 you can no longer run a recent version of Chromium AT ALL - the older posts here refer to version 22 or so, and at the time of writing the current version is in the mid 40's - and does not IIRC have any GPU hardware acceleration.
    – SlySven
    Commented Dec 28, 2015 at 1:24

Install Chromium on your Raspberry Pi with apt-get

At first, we have to update our packages. Open a terminal and type in:

sudo apt-get update

Then, you can install it also by using the packet manager:

sudo apt-get install chromium --yes

Alternatively you can install the package chromium-browser instead of chromium. That’s all! If you are connected through SSH or not using the graphical user interface, you should start (startx). Otherwise you can also establish a remote desktop connection. Now click the start button and navigate to “Internet” where you will find the Chromium shortcut.

Install Chromium on Raspberry Pi’s by using git

If you want to compile the Raspberry Pi Chrome (Chromium) Browser yourself, visit their Google Source repository where you can also check the code. The code is not available on GitHub, but that makes no difference for cloning and compiling the repository. But you should know that the files to download are about 15 gigabyte (after installing in fact 22 GB). This is why I recommend the first option, if you only want to install it quickly. If the installation above failed (for any reason) or you want to inspect / change the code, this is how you can do it (you must have a Raspberry Pi Model 2B / 3, because the models before have not 4 kernels): If you haven’t already installed git, you have to install it first:

sudo apt-get install git

Next, we clone the whole repository to a specific folder, which we create and then go into this directory.

sudo mkdir /opt/chromium
cd /opt/chromium
sudo git clone --depth 1 https://chromium.googlesource.com/chromium/tools/depot_tools.git

Now you can check out the needed files (about 15 GB). Make sure that your micro SD card (32GB or more) has enough empty disk space.

export PATH=$PATH:/opt/chromium/depot_tools
nice fetch --nohooks --no-history chromium

Depending on your internet speed this step can take a while. After finished downloading all files, you can compile the project.

gclient runhooks
./build/gyp_chromium -Dcomponent=shared_library -Dfastbuild=1
nice ninja -C out/Release chrome

Based off here

Google Chrome installation instruction

Note: Exagear, which is needed is not free it does cost a few bucks for a license!

Configure Raspbian

  1. Google Chrome is CPU intensive application, therefore, we recommend to increase swap space. Open configuration file in Terminal (command line) using the following command:
$ sudo nano /etc/dphys-swapfile

Raspbian has 100MB of swap by default. You should change it to 2000MB in the configuration file. So you will have to find this line:


And then change it into:


Press F3 key to save changes and F2 to close the file. Then restart dphys-swapfile to apply changes:

$ sudo /etc/init.d/dphys-swapfile stop
$ sudo /etc/init.d/dphys-swapfile start

Install ExaGear Desktop

  1. Download ExaGear Desktop archive with installation packages and license key. Unpack the downloaded archive by entering the following command in Terminal:
$ tar -xvzpf exagear-desktop-rpi3.tar.gz
  1. Install and activate ExaGear on your RPi by running install-exagear.sh script in a directory with deb packages and one license key:
$ sudo ./install-exagear.sh

Launch guest x86 system

  1. Enter the guest x86 system by using the following command:
$ exagear

Starting the shell in the guest image /opt/exagear/images/debian-8

  1. Now you are in the x86 environment that can be checked by running the arch command:

     $ arch
  2. It is recommended to update apt-get repositories on the first launch of the guest system:
$ sudo apt-get update

Install Chrome

  1. Download Google Chrome:

       $ wget http://mirror.retrosnub.co.uk/apt/google/pool/main/g/google- chrome-stable/google-chrome-stable_48.0.2564.116-1_i386.deb
  2. Install Chrome:

      $ sudo dpkg -i google-chrome-stable_48.0.2564.116-1_i386.deb
      $ sudo apt-get install -f
      $ sudo rm -f /etc/apt/sources.list.d/google-chrome.list

Run Chrome

Based off here

Not the answer you're looking for? Browse other questions tagged or ask your own question.