When I connect to my RPi via SSH and type airmon-ng it shows me the wifi cards, as expected. But when I type the command to look for networks, with airodump-ng, it slowly starts to lag, freezes so I have to disconnect from SSH.

Is there a way to prevent this from lagging?

  • Did you find any question?
    – Suncatcher
    Jul 1, 2018 at 15:00
  • 1
    Same here. I can do a capture using airodump, then when I attempt to run airodump again, it hangs, and then everything drags. Even executing arbitrary commands in the shell is slow after exiting. htop shows nothing out of the ordinary (CPU at near 0%, low memory usage). None of the answers here help. RPI 4B running Kali. Jan 10, 2021 at 1:14

3 Answers 3


You need to determine what makes you lag. It is very hard to improve things without knowing what there is to improve.

There are 2 possibilities that I see at the moment :
1- The cpu is overloaded by airodump-ng and possibly other processes.
2- You are connecting via SSH through wifi and having both overloads the network.

Using top or htop can give you an overview of the running processes. If you see that airodump-ng takes all cpu then you can't really do anything about it. If there are other processes taking cpu, try to kill them if they are not absolutely essential.

Have you tried running airodump-ng without SSH?


Not a complete answer, but I think it's something to do with the on-board chip.

I spent several days trying to fix this, trying everything I could find online, including trying multiple different OS's. Nothing worked.

I just tried some cheap $30 USB adapter that a friend bought on Amazon though, and it worked immediately. I'd save your time and just buy an adapter unless that isn't an option for some reason. Using the on-board chip also has the severe limitation that you obviously loose your wireless SSH connection as soon as you switch to monitor mode, meaning you have to do everything over a wired connection (unless you have it done via an automated script).

To address the accepted answer, assuming the OP has the same problem as me (it certainly sounds like it), this is not an issue related to memory or CPU usage. While the device is lagging, CPU usage and memory are near-zero; as reported by htop:


Launching airodump-ng seems to be the trigger, and the only resolution is to restart the device.

  • This is the only answer which indicates what the real problem most likely is; although it isn't explicit the OP was almost certainly using wifi to connect, ssh in, and then use the same interface for scanning. I think there is a horrendous feedback loop implicit in that (depending on the scan, you are getting a readout of all your own messages, including all the messages that are reports on all your messages...).
    – goldilocks
    Jan 14, 2021 at 17:14
  • @goldilocks I was focusing on "But when I type the command to look for networks, with airodump-ng, it slowly starts to lag, freezes so I have to disconnect from SSH", which is what lead me here from search. Even over a wired connection, airodump-ng causes a slow degradation of general performance and eventually gives up itself. It could be a feedback loop, although I don't notice an increase in traffic while it's happening, and an external adapter resolves it ¯\_(ツ)_/¯. I'm just glad I can start moving forwards after buying a cheap tool. Jan 14, 2021 at 17:43

I can't think of anything very good, but I'll give you what I have at the moment:

You could overclock your pi with raspi-config

A better card may potentially help, but this part is unlikely.

To say the least: Raspberry pis are not very powerful, which limits their performance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.