I recently installed Raspbian on my Raspi B+ and everything - including external usb hub with 2 usb hdds - worked fine. Today, I realized that I could not access the Raspi via LAN (cable) and that the red and green led shined continuously. I made a research and tried all advices, but noting worked. I removed the micro SD and windows explorer shows that it has a size of 56 mb (instead of 16 gb) and there are hardly no files on it:

(folder overlays is empty)

Is this normal? If yes, why else wouldn't it boot? If no, what can I do apart from re-installing the os?



This is "normal", specifically:

  • The default Raspbian (NOOBS) installs a "boot" partition on the SD card that is 56MB. This is the only part of the SD card that is (normally) readable in a Windows or Mac machine. The rest of it is readable by Linux.
  • The boot partition contains files needed for boot (including the Linux kernel image). The image that you provided shows SOME of the files needed for boot, but not all of them. If needed files are missing, the device won't boot (for example, there should be a kernel.img file on there).

Generally, most likely causes for not booting are issue with SD card or issue with power supply. If you have an extra SD card, try imaging it with Raspbian. If it boots, you'll know the issue is with you current SD card.

  • Well, I tried your approach and it really seems that my sd card is issued. Is there a way to transfer the content of the old to the new sd card using windows? – holgrich Oct 21 '15 at 6:11
  • And: Should the sd card show some more files under windows like kernel.img, start.elf, ... (please see screenshot linked above) – holgrich Oct 21 '15 at 6:26
  • Yes, it should show more files under windows. For reading the rest of the SD card, google something like "read ext4 windows" - you need to install a program to be able to do it. – Brian Oct 21 '15 at 12:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.