9

So I have a bug in a script in my init.d directory and bottom line...I can't completely boot the pi.

How can I boot into runlevel 1 (single user mode) so I can fix the bug?

16

That's not exactly a way to enter runlevel 1, but there is "safe mode" boot option in raspberry Pi firmware. To enable it, you have to insert a jumper between pins 5 and 6 on P1 (GPIO) header when booting.

Safemode pins

If you do this, bootloader will ignore the config.txt file (except from avoid_safe_mode option which can be used to disable this feature) and will try to boot kernel_emergency.img (if available) instead of kernel.img.

Default kernel_emergency.img has special emergency initramfs build in and it will boot to this busybox based OS so that you can fix the problems in your OS manually (or change kernel boot parameters to run runlevel 1 at next boot). Remember to run sync before powering down since reboot or shutdown commands may not work.

  • That's exactly what I was looking for. – Deac Karns Dec 2 '12 at 2:32
5
  • Hit shift when starting up.
  • Hit "e" to edit config
  • tab over to cmdline.txt
  • add to the end of the line

    init=/bin/sh

  • hit ok, then Esc to boot...... it will boot you in to a command line

    # /etc/init.d/mountall.sh (this will do something)

    # mount -n -o remount,rw / (this will remount / so you can make changes)

  • now you should be able to edit the init.d config......

  • when you reboot again.... hold shift and remove the init=/bin/sh
  • Excellent! I'd found instructions to init sh but was missing the remount stuff I needed. Thanks! – Richard Turner May 13 '16 at 7:18
3

Several of the other answers here are now incorrect:

  • The GPIO jumper pin method was removed from the upstream OS, so it only works now if you're using a NOOBS image

  • Raspbian Jessie's move to systemd breaks the init=/bin/sh hack. When you do this, it complains, can't access tty: job control turned off

Fortunately, there is a solution that works, which actually gives real single-user access: add a space and a 1 at the end of cmdline.txt, right after the rootwait parameter.

The hold-Shift boot menu doesn't exist with the stock Raspbian Jessie OS image, so you'll have to do this by editing /boot/cmdline.txt from another computer if you aren't using the NOOBS image.

2

I couldn't find a way to force the pi to boot into runlevel 1 so I fired up a fedora live disk I had laying around and used the terminal to remove the script in question from the /etc/init.d directory

1

If you want to access and change SD card Linux partition files from Windows you can do it with one of these utilities.

  • Welcome! Please take the tour and visit the helpcenter. Whilst this may theoretically answer the question, it is preferable to include the essential parts of the answer here, and provide the link for reference. In fact we're enforcing this policy: please edit so that the answer stands on its own should the link break in the future. If it is not edited within 48 hours it will be converted to Community Wiki. – Jacobm001 Jul 31 '17 at 15:59
1
  1. Boot into runlevel 1

    $ sudo init 1
    
  2. After booting into runlevel 1

    $ passwd
    

NOTE: to runlevel 1, change the file /etc/inittab from id:2:initdefault: to something similar like: id:1:initdefault:

  • 2
    Is that really booting into runlevel 1, though? I mean, it can hardly be done if the machine isn't booted in the first place, can it? – Bex Sep 10 '14 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.