1

I have been running a Raspberry pi 2 as a web server for the last week or two. Unfortunately it seems to totally freeze up and stop working altogether after fairly arbitrary intervals but usually between 12-24 hours of being left on.

When I say freeze I mean a total stop on all processes. There are no scheduled crontab activities running, no entries in logs and no access to the pi via ssh or http.

I have desperately tried in vain to diagnose the issue. I run a script in from crontab which every ten minutes checks and logs the status of ifconfig and the web server to see if it is up and running, and this shows no issues here. It logs everything OK and then just stops reporting when the device crashes.

I have scoured through every log in /var/log and there is nothing which appears to be a report of an error.

So I suspect the power supply - I am using the power adapter that I bought with my device so it should be adequate, however I live in an old building and I would not vouch for it being well wired and we have been known to have regular power drops.

However, if the issue were caused by drops in power would I not be able to expect to see the pi actually reboot at least some of the time?

And yet I can be sure this has never happened because it would be clearly logged by my own script and presumably in the pi's own logs.

I was originally running Raspian wheezy but upgraded to jessie hoping that the upgrade may help, and have checked I am running the latest firmware, but no joy.

Any advice?

EDIT / UPDATE

I noticed the last time that it crashed that the green 'act' LED next to the power LED was fixed on solid. So I had no access to the pi via http or ssh and the crontab tasks that are scheduled did not run (I found when I checked my logs). I had to reboot the system by powering off as usual. I do not have it connected to a monitor so I don't know if there would be any error message, but there was nothing in /var/log/messages ...

Does the green LED being fixed on point at an SD card issue?

It is also worth noting that I am now running watchdog, and since running it this is the first time my system crashed, having managed a record 4 days up ... but when I checked my logs it has this entry in messages:

Oct 24 13:17:18 raspberrypi kernel: [   27.064275] watchdog stopped

this appears to be shortly before it crashed, as the crontab tasks scheduled made a last log entry at 13:30:00 and normally runs every ten minutes.

  • If the power cuts in and out it should reboot normally. – goldilocks Oct 21 '15 at 20:39
  • @goldilocks I have added some more information. I wonder if this helps isolate the issue. Thanks – Sam Redway Oct 24 '15 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.