1

I'm trying to set the rotation on the Raspberry Pi to portrait mode. On startup the RPi GUI is shown looking fine but if I move anything (a window for example) then the screen tears (not fully repainting the background). I was wondering if this is connected to the monitor HDMI settings and I have tried several different options all to no avail. I followed the WHICH VALUES ARE VALID FOR MY MONITOR? instructions and the results are below. I also have the edid.dat file if anyone would find that useful.

I'm really stumped how to stop the screen tearing like this - needless to say this only happens when display_rotate are set to 1 or 3.

Any ideas would be very welcome!

pi@raspberrypi ~ $ /opt/vc/bin/tvservice -m CEA
Group CEA has 15 modes:
  (prefer) mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
           mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
           mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
           mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
           mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
           mode 6: 720x480 @ 60Hz 4:3, clock:27MHz x2 interlaced
           mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced
  (native) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive
           mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive
           mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive
           mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive
           mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced
           mode 21: 720x576 @ 50Hz 4:3, clock:27MHz x2 interlaced
           mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced
           mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive 

pi@raspberrypi ~ $ /opt/vc/bin/tvservice -m DMT
Group DMT has 10 modes:
           mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive
           mode 8: 800x600 @ 56Hz 4:3, clock:36MHz progressive
           mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive
           mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive
           mode 32: 1280x960 @ 60Hz 4:3, clock:108MHz progressive
           mode 35: 1280x1024 @ 60Hz 5:4, clock:108MHz progressive
           mode 47: 1440x900 @ 60Hz 16:10, clock:106MHz progressive
           mode 51: 1600x1200 @ 60Hz 4:3, clock:162MHz progressive
           mode 58: 1680x1050 @ 60Hz 16:10, clock:146MHz progressive
           mode 82: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive 
pi@raspberrypi ~ $ /opt/vc/bin/tvservice -s
state 0x12001a [HDMI CEA (1) RGB full 4:3], 640x480 @ 60.00Hz, progressive 
  • You could try this; be sure to read the comments. In case it's not clear, this means not setting any rotation in config.txt. – goldilocks Oct 25 '15 at 19:29
  • Thanks for your response. I just installed the latest firmware update and it fixed the problem! – James Hunt Oct 25 '15 at 20:17
  • Can you post that as an answer quickly? – goldilocks Oct 25 '15 at 20:19
1

So seems I basically needed to update the firmware and this was the answer...

  • I updated the GPU firmware using sudo rpi-update but the tearing is still present on display_rotate=3. Did you do anything else? – DrenImeraj Oct 26 '15 at 18:25
  • @goldilocks sorry for bothering you, but James doesn't seem available. I have executed sudo rpi-update and sudo apt-get upgrade but nothing happened. Did I miss anything? – DrenImeraj Oct 30 '15 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.