15

I'm using an RPi 2 Model B and I have connected a Raspberry Pi Camera Rev 1.3 to it.

I have checked to make sure that the connection is correct (the power LED on the camera is on).

I've run:

rpi-update
apt-get update
apt-get upgrade

I have the following configuration in /boot/config.txt:

start_x=1
gpu_mem=128
start_file=start_x.elf
fixup_file=fixup_x.dat

I've gone to raspi-config and tried to enable my camera with no success. When I try to enable it exits back to main config page but when I go back to the camera configuration page its still at disable. I tried entering enable and restarting anyways.

Each time I run raspistill -o image.jpg I get the following error:

mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not detected. Please check carefully the camera module is installed correctly

Not sure where my problem is. Does anyone have any insight on this?

4
  • Don't you mean apt-get update without install part?
    – rav_kr
    Oct 27 '15 at 10:45
  • @rav_kr Yes. Sorry about that.
    – sphchow
    Oct 27 '15 at 10:52
  • Your boot config indicates the camera firmware is indeed enabled (ignore the raspi-config disable thing - the camera page doesn't show the current status). So, either your camera is installed incorrectly (blue side of ribbon facing the ethernet ports? pushed in fully?) or your camera module is simply defective (rare, but it does happen).
    – Dave Jones
    Oct 28 '15 at 8:25
  • 3
    @DaveJones After taking a closer look into the installation of the camera. My blue side of the ribbon is facing the correct way. BUT it looks like I accidentally connected it to the DISPLAY port instead of the CAMERA port. DERP... Works great now. Thanks Dave.
    – sphchow
    Oct 28 '15 at 18:31
22

I just had this same problem. Here is what eventually worked after reading this (From the comments it looks like you had the same issue as I did):

  1. vcgencmd get_camera (Returned supported=1 detected=0)
  2. Check to make sure ribbon was facing the right way (it was)
  3. Check to make sure ribbon is all the way in the connector slot (it was)
  4. Check to make sure ribbon is in proper connector slot: the one between the ethernet port and the HDMI port (it was NOT!)
  5. Reconnect camera in the proper slot
  6. vcgencmd get_camera (now returns supported=1 detected=1)
  7. Good to go!
2
  • 1
    Go to raspi-config and also make sure the camera is enabled.
    – Jason
    Nov 5 '18 at 23:03
  • I did all this, everything you listed was correct but I still couldn't take a photo with raspi-still. Turns out a service in the background (in my case motion) was already running and using the camera, which was causing the error for me.
    – Sean
    Jul 6 at 20:06
1

My problem was a little connector between camera len (im not sure what kind of device is it) and board.

Just smoothly "click" it on place.

I marked it on photo, red color:

enter image description here

0

I had the same problem and the ribbon cable was backwards. Flipped the ribbon cable from the camera and it worked.

0

I've experienced numerous problems with the camera connector on the Raspberry Pi Zero W board. The locking tab often falls out, leaving the cable loose. I've also had camera modules simply stop working after days or weeks, requiring replacement.

They are fun little units, but extremely fragile and from my experience with 3 different Pi Zero W boards and 5 camera modules, not very reliable or durable.

0

My problem was the conector on the camera board was not making contact properly, not the long wire but the small one on the board between the camera and its own board.

-1

You can enable the I2C interface.I enabled it and it worked fine.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.