1

I've been working on FTP server for RPi but Windowss UWP sandbox is a real nightmare for me. I need full privilages to the file system on RPi which sandbox doesn't want to accept. Can I build app for RPi without UWP? I know I'll probably lose GPIO support but FTP doesn't need GPIO anyway...

1

Since I don't need to have access to gpio with this app, I can create a Win32 project, add ARM platform to it, compile and then copy it to RPi via built in Win 10 IoT FTP. You can then start your app using SSH (PowerShell or cmd).

  • Oh very nice solution (if you dont need GPIO) can you please update your answer with the command you used to start the app from cmd? (Also, please mark it as accepted if it worked for you) – Piotr Kula Nov 3 '15 at 11:49
  • @ppumkin use any SSH (like putty for example), write .exe path ("C:\IoTApps\YourApp.exe" for example) and press enter. From PowerShell use: & "C:\IoTApps\YourApp.exe" PS.: sorry for delay – Quest Nov 4 '15 at 20:53
  • Ohh right, I thought I tried that and didnt work, but I suppose it was a Universal App and not a Win32 App. Cool – Piotr Kula Nov 4 '15 at 20:54
  • 1
    Yeah you can't run Universal Apps that way.. But you can register them as default app so they will start when RPi starts.. – Quest Nov 4 '15 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.