1

My 320x240 2.8" PiTFT (#1601) reached me yesterday. I install Jessie-based PiTFT 2.4" and 2.8" Resistive Image for Pi 1 and Pi 2 (September 24, 2015) image to my sdcard. At first everything seems perfect. I can see hdmi output on my screen. Both console and desktop environment seems perfect. Then I tried touch thing, it seems perfect too (tested it desktop environment, and console with ts_test).

After that, i want to try pygame for gui, and I realize, cursor going crazy. Not just a calibration problem, pointer moves around randomly, even when I don't move my sytlus. Here is a video of that: https://www.youtube.com/watch?v=9AgkgpnXc6k

And my code: https://gist.github.com/yozel/679b331570f0dc5d45eb

What's going on? What have i done wrong?

  • I have the same behaviour. The PiTFT works well with the X interface, the calibration software but it doesn't work on console : GPM or pygame. – user36490 Nov 5 '15 at 20:47
  • is there any support from adafruit for gpm support ? – y_nk Apr 25 '16 at 16:16
2

Try installing Wheezy instead of Jessie:

I had the same problem on the 2.8" capacitive TFT after upgrading Raspbian to Jessie; but it runs ok with latest Wheezy release.

  • I have tried this just now and it works! Really, really thank you! – yozel Dec 17 '15 at 21:27
  • 1
    what files changed ? how to make it work on jessie ? – y_nk Apr 25 '16 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.