0

Just got started recently with Raspberry Pi 2.

One day 1, fired up RPi2, connected it to Laptop using Ethernet and did SSH to the device. I was also able to open up wpa_gui tool and see the listed WiFi networks. My WiPi dongle was working well and blue light flashing.

Today on Day 2 when I plugged in my WiPi, there is no Blue light, just one micro-second flash the moment it is plugged in and dead after that. "ifconfig" does show me wlan listed. wpa_gui shows nothing. Seems the dongle went dead.

pi@raspberrypi ~ $ iwconfig

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dB  
          Retry short limit:7   RTS thr:off   Fragment thr:off  
          Power Management:off  
lo        no wireless extensions.  
eth0      no wireless extensions.

pi@raspberrypi ~ $ sudo lsusb

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.  
Bus 001 Device 007: ID 148f:5370 Ralink Technology, Corp. RT5370 WirelessAdapter

Can someone help troubleshoot this?

Added an image of wpa_gui

NEW INFO: "dmesg" output on connecting WiFi Dongle:

[ 1402.128972] usb 1-1.5: new high-speed USB device number 5 using dwc_otg
[ 1402.246605] usb 1-1.5: New USB device found, idVendor=148f, idProduct=5370
[ 1402.246630] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1402.246647] usb 1-1.5: Product: 802.11 n WLAN
[ 1402.246664] usb 1-1.5: Manufacturer: Ralink
[ 1402.246680] usb 1-1.5: SerialNumber: 1.0
[ 1402.269406] ieee80211 phy1: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -19
[ 1402.269435] ieee80211 phy1: rt2800_probe_rt: Error - Invalid RT chipset 0xb9b3, rev faa8 detected
[ 1402.269453] ieee80211 phy1: rt2x00lib_probe_dev: Error - Failed to allocate device
[ 1402.270736] usb 1-1.5: USB disconnect, device number 5

3

The problem is fixed now and I am able to access Internet (Check mails / youtube, etc) using the WIFI Adapter. Here's what I did:

First I connected my Pi directly to the router on Ethernet and upgraded/updated all the packages and firmware.

Then I ran the following commands:

sudo ifdown wlan0  
sudo ifup wlan0

During ifup I found that the DHCPDISCOVER request was not being responded to after several tries and finally an error occurred that said

wpa-roam can only be used with the manual inet method

Then I did some more research and did the following change in /etc/network/interfaces file from:

wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf  

TO

wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Again I ran the command sudo ifup wlan0 and it connected with the blue light flashing.

Then I rebooted the system.

0

This could be a device driver bug, or something unorthodox done by the OEM. It is odd that it reports itself as one thing:

ID 148f:5370 Ralink Technology, Corp. RT5370 WirelessAdapter
   ^^^^^^^^^

But then the driver later complains that it is something else:

rt2800_probe_rt: Error - Invalid RT chipset 0xb9b3, rev faa8 detected

I have a wifi adapter using the 5370 chip; actually two but they are identical. They require firmware that is in the vanilla kernel and included with Raspbian and work fine on the pi.

I think the reporting via lsusb should be accurate -- this is something simple done via the USB protocol and does not require any device specific driver; the purpose is to allow the OS to identify the device so it can select an appropriate driver, if available.

However, since manufacturers generally supply their own proprietary drivers for mainstream operating systems and do not claim to support anything else, they are free to do "something unorthodox" which may be what is happening here.

In short there's nothing you can do about this. With regard to wifi adapters, since they are cheap and usually easy to obtain, my recommendation is (if possible) to buy something in a local, reputable electronics store that will take a return within 7 days without any hassle. First check what is available and do a bit of research, then go with the best option.

  • Hello Goldilocks, You were probably right in pointing out a driver problem. Thanks for the detailed explanation. Based on your directions, I was able to fix the issue. Thanks again !!! – Aditya Dutta Nov 6 '15 at 6:36
  • Are you being sarcastic, lol? Anyway, good for you for getting it to work. – goldilocks Nov 6 '15 at 11:28
  • Hello Goldilocks, I am sorry if I sounded sarcastic. But it is true you pointed me to the right direction. Thanks again !!! – Aditya Dutta Nov 25 '15 at 3:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.