1

I have been trying to install libssl-dev on rpi2B with the following version of raspbian - Linux raspberrypi 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l

I have already tried sudo apt-get update/upgrade but the problem is still not resolved. I am attaching a snippet of the messages in the terminal during installation.

sudo apt-get install libssl-dev

Reading package lists... Done

Building dependency tree Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libssl-dev : Depends: libssl1.0.0 (= 1.0.1e-2+rvt+deb7u11) but 1.0.1e-2+rvt+deb7u17 is to be installed

E: Unable to correct problems, you have held broken packages.

-1

I had the same problem, that I couldn't get libssl-dev even after an apt-get upgrade.

However, once I did another apt-get update AFTER running the apt-get upgrade ... then it worked.

No idea why, but there you have it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.