1

This question already has an answer here:

I've installed Raspbian Jessie today and I'm having problems with an Edimax EW-7811Un 802.11n that was working under Raspbian Wheezy. It shows up fine with lsusb and sudo iwlist wlan0 shows my Wifi network (broadcast from Asus RT-AC68U) but ifconfig indicates the device isn't connecting with and obtaining an IP from the router.

Anybody have similar issues or solutions? Outputs below.

/etc/wpa_supplicant/wpa_supplicant.conf

network={
ssid=“network”
psk=“key”
scan_ssid=1
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

/etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

marked as duplicate by goldilocks Nov 6 '15 at 18:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I would suggest you to have a look at this answer : raspberrypi.stackexchange.com/questions/37920/… – dhruvvyas90 Nov 6 '15 at 18:32
  • "I've installed Raspbian Jessie" -> Yes, then you changed the default settings. Why? If the duplicate does not solve your problem, please add details to explain how and why you modified things and what you expected your changes to accomplish. – goldilocks Nov 6 '15 at 18:57
  • Thank, yes. I took a look a the raspberrypi.stackexchange.com/questions/37920/… link and returned /etc/network/interfaces to the default. I'm confident of the SSID and wifi key in /etc/wpa_supplicant/wpa_supplicant.conf and dhcpd.conf i haven't touched at all. I tried a second wifi device (Raillink) and that show up with lsusb and scans normally, but again doesn't get an IP. I'm setting up headless. No problems at all on eth0. – Nick Fraser Nov 7 '15 at 3:29
  • I'm just trying to get wlan0 working on dhcp. I don't want a static ip. – Nick Fraser Nov 7 '15 at 3:41
  • Issue solved. I think it was issue caused by Edimax dongle being in the USB port during Jessie setup. I re-installed without the dongle present and the device found an IP as soon as I set the SSID and key in wpa_supplicant.conf and rebooted. – Nick Fraser Nov 9 '15 at 13:41

Browse other questions tagged or ask your own question.