This is my setup:

  • Raspberry Pi w/Raspbmc
  • 8GB Transcend SDHC card
  • Yamaha RX-V1900 receiver
  • Westinghouse 40" flat panel TV

When the Pi is directly connected to the TV by HDMI, the output is sharp (TV switches to the HDMI output of the Pi) and the screen doesn't change resolutions every 5 seconds.

When the Pi is connected to the TV through the AV receiver when it's powered up, it appears that the Pi cannot detect the TV's resolution; it keeps rotating through resolutions trying to find one that works.

If I power up the Pi attached directly to the TV (so that the screen is properly detected) and then plug it into the receiver, the screen stays perfect (no resolution changes).

I have tried a number of config.txt options but nothing seems to work.

Using the tvservice application I was able to find the resolution that appears to be the best:

pi@raspbmc:~$ /opt/vc/bin/tvservice -s
state: HPD high|HDMI mode|HDCP off|composite off (0x12001a), 1366x768 @ 60Hz, progressive

pi@raspbmc:/var/log$ /opt/vc/bin/tvservice -m CEA
Group CEA has 7 modes:
           mode 1: 640x480 @ 60Hz, progressive
           mode 2: 720x480 @ 60Hz, progressive
           mode 3: 720x480 @ 60Hz, progressive
  (native) mode 4: 1280x720 @ 60Hz, progressive
           mode 5: 1920x1080 @ 60Hz, interlaced
           mode 6: 720x480 @ 60Hz, interlaced
           mode 7: 720x480 @ 60Hz, interlaced

pi@raspbmc:/var/log$ /opt/vc/bin/tvservice -m DMT
Group DMT has 10 modes:
           mode 4: 640x480 @ 60Hz, progressive
           mode 6: 640x480 @ 75Hz, progressive
           mode 9: 800x600 @ 60Hz, progressive
           mode 11: 800x600 @ 75Hz, progressive
           mode 16: 1024x768 @ 60Hz, progressive
           mode 17: 1024x768 @ 70Hz, progressive
           mode 18: 1024x768 @ 75Hz, progressive
           mode 28: 1280x800 @ 60Hz, progressive
           mode 81: 1366x768 @ 60Hz, progressive
           mode 85: 1280x720 @ 60Hz, progressive

pi@raspbmc:~$ /opt/vc/bin/edidparser edid.dat
Enabling fuzzy format match...
Parsing edid.dat...
HDMI:EDID version 1.3, 1 extensions, screen size 98x58 cm
HDMI:EDID features - videodef 0x80 !standby !suspend active off; colour encoding:RGB444|YCbCr422; sRGB is not default colourspace; preferred format is native; does not support GTF
HDMI:EDID found monitor name descriptor tag 0xfc
HDMI:EDID monitor name is Westinghouse
HDMI:EDID found monitor name descriptor tag 0xfc
HDMI:EDID monitor name is SK-42H240S
HDMI:EDID found monitor range descriptor tag 0xfd
HDMI:EDID monitor range offsets: V min=0, V max=0, H min=0, H max=0
HDMI:EDID monitor range: vertical is 49-76 Hz, horizontal is 15-49 kHz, max pixel clock is 90 MHz
HDMI:EDID monitor range does not support GTF
HDMI:EDID failed to find a matching detail format for 1366x768p hfp:40 hs:32 hbp:58 vfp:3 vs:5 vbp:40 pixel clock:73 MHz
HDMI:EDID calculated refresh rate is 60 Hz
HDMI:EDID guessing the format to be 1366x768p @60 Hz
HDMI:EDID found preferred DMT detail timing format: 1366x768p @ 60 Hz (81)

This is my latest /boot/config.txt file:

pi@raspbmc:~$ cat /boot/config.txt

What is going on here? Is there any way that I can get the Pi to detect the resolution of the TV through the receiver?

  • hdmi_mode and hdmi_group solved my problem of routing my HDMI through a receiver too. Thank you to this page!
    – Pugwash
    Commented Feb 25, 2013 at 20:00
  • Did you get a solution? I'm facing the same exact issue, even the hdmi_safe is not working. Regards, Sergio S.
    – user8406
    Commented Jul 10, 2013 at 3:58

2 Answers 2


Try to add the following 2 lines to your config.txt:


This sets the used resolution to CEA (hdmi_group=1) and 1280x720p (hdmi_mode=4).
Add this to your config.txt and reboot.

No idea if this will work but it selects a resolution permanently (you can of course change it by editing your config.txt again).


Awesome suggestions. Attached raspberry pi -> receiver (HDMI) -> TV (HDMI) and running Openelec. Every time I would switch sources on my receiver, every time I tried to go back to raspberry pi I received basically a blank screen (input not detected/supported). I added these lines to my config.sys (Added to the very bottom, after all the hash tags ###):


(Mode 16 = 1080p @ 60Hz) Now I can switch inputs on my receiver and go back to the raspberry pi without problems. Thanks!

Update - this did not end up working consistently. I'm thinking it may have to do with CEC control/command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.