0

Having difficulty with the monitor displaying anything other than black and white lines, even after changing the config.txt file in the latest version of NOOBS in os/Raspian/boot/config.txt according to guidelines: https://learn.adafruit.com/adafruit-5-800x480-tft-hdmi-monitor-touchscreen-backpack/raspberry-pi-config.

I am using a Raspberry Pi 2 Model B. The usb power and hdmi cables for the monitor are from Adafruit, and are very short. the power supply is a NorthPada USA Micro USB Mains Power Wall Supply Charger 5V 2000mA.

Both a mac-formatted SD card and the Raspberry Pi pre-installed card had the same effect, so I don't believe it is a card issue. The monitor listed above is also the second monitor that I tried, so I've also ruled out the monitor as the problem.

The ACT light flickers but not for an extended period of time, and not in a particular pattern.

current monitor display

  • Although it might be beside the point, there's not really a bios. If you get much of any activity on the green ACT light at all that isn't a steady rhythm of blinks, then it has booted the OS to some point. If, while this happens, you get that picture on a plain old HDMI screen and never anything else, it implies that at least the HDMI jack, related circuitry, or GPU is broken. What happens if you unplug the pi, completely remove the SD card, then plug it back in? Is the screen any different, or the same? – goldilocks Nov 10 '15 at 10:24
  • Without the SD card, the screen stays completely black. This is the second screen I've tried (different model/make), along with different hdmi and usb cables for the monitor that gave me the exact same results. – Matt Nov 10 '15 at 19:47
  • Some of the firmware on the SD card has to do with the GPU (otherwise it couldn't be updated), so that may be required just to start any display, which would account for the difference. I.e., it's still most likely broken hardware on the board if you've tried multiple monitors, multiple cables, multiple SD cards, and multiple SD card images. In which case you have a warranty claim (1 year in the US). – goldilocks Nov 10 '15 at 19:57
0

I have learned that the problem was due to a problem with the HDMI hardware on the board. Apparently there was a bad batch at the factory.

I am unable to use an external monitor on this board, but otherwise it is functional and I have been able to program it using SSH.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.