6

I'm trying to boot up Exton's Android build on Raspberry Pi 2, but I seem to be getting the rainbow screen.

Here is what I have - 4 partitions as follows

  • boot which has 512 MB, flagged as bootable
  • system which has 1 GB
  • cache which has 512 MB
  • data which has over 10 GB

I used to GParted through Elementary OS - Freya to format and partition.

My config.txt file looks like this -

hdmi_force_hotplug=1
hdmi_drive=2
config_hdmi_boost=4
disable_overscan=1
framebuffer_width=1280
framebuffer_height=720
kernel=zImage
device_tree=bcm2709-rpi-2-b.dtb
initramfs ramdisk.img #0x01f00000
mask_gpu_interrupt0=0x400

I've tried different SD cards (different manufacturers) and checked the power input. Everything seems to be fine but I still get the rainbow screen.

Note: I tried to load berryboot's bootloader for Pi 1 (even though mine is Pi 2) and it seems to be going past the rainbow screen and showing the OS setup screens.

But berryboot's bootloader for Pi 2 or Exton's build or other similar builds don't seem to go past the rainbow screen.

Any help would be highly appreciated.

UPDATE: I tried to boot Windows IoT yesterday. Still getting the rainbow screen. One of the SD cards was a Class 10.

  • which USB devices do you have attached? – ths Nov 11 '15 at 13:42
  • I tried powering up with and without the USB devices, still no luck. I have a USB dongle connected to Pi which has the keyboard and mouse connected to it. – Aswin Ramakrishnan Nov 11 '15 at 14:19
  • Power supply problem? – Patrick Cook Nov 12 '15 at 4:02
  • I just tried to boot Raspbian and it loads up right away.. I don't think it's the Power supply problem.. I come across a LOT of threads where people were saying it was the SD cards.. But I seriously doubt it.. There has to be something going on with the bootloader or the way Raspberry Pi works / boots up. (I seriously don't think Class 10 SD cards is the issue either, because I've tried booting Windows IOT and Raspbian, Windows IOT leads to rainbow screen in ALL the SD cards I've tried but Raspbian boots up right away in every one of those) – Aswin Ramakrishnan Nov 12 '15 at 4:21
  • Sanity checking things not explicitly mentioned in your question: Are your partitions formatted per the installation instructions (i.e. boot/FAT32, system/any, cache/ext4, data/ext4)? Not that it should make any difference, but is there a good reason for you doubling the size of the system partition? You've linked to the second most recent build (the most recent being, I think, here). Is this deliberate? – goobering Feb 16 '16 at 10:24
0

Just a hunch but it's worth a shot: do you have an HDMI cable or even an HDMI-VGA adapter connected? I ran into power issues due to HDMI sucking juice.

  • I did have a HDMI-VGA adapter connected. But I don't understand why it would work with some bootloaders and not with others. Especially Windows IoT's. Did you have any luck without connecting to HDMI port? (For example, a bootloader that failed with HDMI connection worked when you didn't connect HDMI port on boot?) – Aswin Ramakrishnan Feb 16 '16 at 15:26
  • I have no idea why the bootloader could make a difference (there are too many possibilities) but now since you confirm my hunch I am pretty sure the adapter's the problem. My solution was to use one that works with an external/additional power source. – PiEnthusiast Feb 16 '16 at 15:33
  • @AswinRamakrishnan it could be because certain boot loaders require more cpu power to run or by default will overclock the pi even marginally which would push your overall power usage by the pi and reduce the voltage available to the hdmi-vga adapter – Mohammad Ali May 20 '16 at 3:22
0

If the Pi won't boot past the rainbow screen, there is an issue with the image installation. You'll need to format the SD card and install a fresh image. This should take care of the issue.

0

This is my go to place for all video issues: https://elinux.org/RPiconfig#Video_mode_options

If it were not Windows IoT, in your /boot/config.txt you could try, which should work: hdmi_safe=1

If that works, then try (N=2, but I have gone as high as 8): config_hdmi_boost=N

-1

The rainbow square is there to show you that the amp rating on your power supply is insufficient. Yes, it has to be 5v but it must also be >= 1A or 1000mA.

if your PSU shows it is >= 1000mA then try another PSU as the one you have may be faulty. It is generally recommended IIRC that running it from a USB port on another computer is not a good idea.

  • my power supply is a 5v ==== 2A, is it too much? because i still get the rainbow square thingy!! – Ali Almoullim Feb 16 '16 at 2:52
  • 4
    A small rainbow square in the top right corner is a power warning. A giant rainbow screen is an indication that your boot has failed. – goobering Feb 16 '16 at 10:06
  • @AliAlmoullim I don't want to hijack this question, but not every power adaptor is the same, some are of questionable quality, and long USB cables for instance can experience power loss. Also having things attached like an external HDD without its own power supply or a keyboard with fancy LED's + HDMI etc etc can draw to much power from your Pi causing it to display the rainbow square in the corner of your screen. – Havnar Feb 16 '16 at 15:27
  • @Havnar okay, i have a wifi usb and hdmi cable but I'm guessing the problem is with the long usb cable power supply. Anyway does this damage the Raspberry Pi or is it ok like that? – Ali Almoullim Feb 19 '16 at 7:01
  • @AliAlmoullim Long usb cables tend to be less efficient and lose power. just try with another, shorter, more high quality cable and see if it makes a difference. – Havnar Feb 19 '16 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.