14

I have a Pi (with Raspbmc installed on it) connected to an LG TV. I disabled the CEC options in XBMC related to turning the TV on/off. However, the Pi keeps turning the TV on when rebooting. I can confirm it's the Pi and not XBMC as the TV comes on before XBMC loads. Is there any way to prevent Pi from turning the TV on? I understand that it sends a signal through HDMI when it comes on, but does it send a "wake up" signal? If so, is there any way to prevent it? It's not fun to come back from work or to wake up and see the TV's been on for hours... Thanks!

1
  • If it helps, the functionality causing this is HDMI CEC.
    – Jivings
    Dec 2 '12 at 9:17
18

Try editing /boot/config.txt to include the line

hdmi_ignore_cec_init=1

If you're using OpenElec, the file is /flash/config.txt

More info on config.txt options can be found on the elinux wiki pages

3
  • Nice, I didn't know about that option.
    – Jivings
    Dec 2 '12 at 19:18
  • damned for me, this option doesn't change anything with my bravia ...
    – Overnuts
    Sep 18 '14 at 8:16
  • I had to mount /boot as rw in order to do, similar to wiki.openelec.tv/index.php/Config.txt#Editing_config.txt
    – rebelliard
    Feb 20 '17 at 17:38
3

Preferences > System > Input Devices > Peripherals > CEC Adapter Settings Uncheck the option: "Switch source to this device on startup"

1

Solution 1. Disable turning TV on on boot and keep CEC adapter active.

  1. Put the following line into the /boot/config.txt
    hdmi_ignore_cec_init=1
    
  2. Update the following Kodi settings in the Settings > System > Input > Peripherals > CEC Adapter
    Switch source to this device on startup = off
    Devices to power on during startup = None
    Wake device when deactivating the screensaver = off
    
  3. Turn TV off manually
  4. Reboot Raspberry

Result: TV is off after Raspberry reboot

Solution 2. Disable turning TV on on boot by disabling CEC adapter.

  1. Put the following line into the /boot/config.txt
    hdmi_ignore_cec=1
    
  2. Turn TV off manually
  3. Reboot Raspberry

Result: TV is off after Raspberry reboot


Raspbian 10 (buster)

Kodi 18.5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.