0

I'm trying to add a a USB hard drive to my pi...

I'm running OpenElec with Kodi for my media, hooked up to TV on wireless connection..

I can't seem to just see the files, so I think I need to mount the drive. I've seen that you can mount it using command lines..

I just dont know how to access the command prompt! When I boot the Pi it goes straight into Kodi. If i try and exit kodi it reboots, i've never seen another menu / interface other than the Kodi menu.

I tried to SSH in using Putty but the connection is refused, again i need the command line for this. How do I get to a command prompt??

I can see files when I navigate to the IP on my windows box, that's about it.

  • Within Kodi I do not believe there is a way to access the terminal, have you looked in the settings in kodi for an option to mount the drive? What was the error code you got when the connection was refused? Does your usb hard drive power up when connected to the pi? – Darth Vader Nov 13 '15 at 8:08
  • I agree, there's no way in Kodi, the problem is you never see anything else other than Kodi, it just boots straight to it.. I managed to SSH in eventually but the usual logins for the pi don't let me in, I just get access denied... I'm going to do a fresh install anyway so I will see how that goes.... – zombiecode Nov 13 '15 at 9:13
1

I literally ran into this problem last night. Here's what you need to do. (Note, I was using raspbmc with Kodi so things might vary slightly)

Click the power button at the bottom of the screen and then choose "exit". It should ask you to press escape but just tap it incase until you get a command prompt. Login and do it quick. Defaults are uname:pi passwd:raspberry Quickly type sudo service kodi stop. This will prevent kodi from restarting. You can restart the service when you're ready to return.

As for the ssh, make sure that it is enabled. In raspbmc you can find the settings under the programs tab.

Also, if the mount is the issue be sure to add it to your fstab.

  • Steven Walton was correct on how to reach the terminal, but for me using osmc on my raspberry pi; the username and password were both "osmc". – JonDoe Mar 12 '17 at 18:29
0

That sounds good, but there might be another way as well. Try logging out(power button, then "logout") and then typing sudo service kodi stop This should do it.

  • Hello and welcome. Could you please explain how your solution differs from Steven's answer? I think it is exactly the same approach. Please note also, that all commands are case sensitive, in this case sudo and kodi have to be spelled with lower caps. Feel free to edit your answer to fix this issue (you can always edit your own questions and answers). – Ghanima Dec 12 '15 at 10:57
  • Sorry, autocorrect on iPad isn't the best – Rajan Phadnis Dec 13 '15 at 8:11
  • It differs because on Steven's it says exit. On my machine, it says just power off and stuff. Also, you don't need to restart Kodi to do what I said in the post. – Rajan Phadnis Dec 13 '15 at 8:16
  • Hmm. In that case my kodi seems to behave differently. There are 4 options in that menu, "Exit" is there, "Logout" is not (might be possible to be configured differently using advancedsettings.xml). "Exit" however exits in my case to the shell with kodi not restarting automatically (but it's not on openelec). – Ghanima Dec 13 '15 at 13:18
  • Oh, what version of OpenELEC, or Kodi are you running? I am running the second newest version of OpenELEC. Is it possible to update directly from OpenELEC TO A NEWER VERSION OF OPENELEC? – Rajan Phadnis Dec 13 '15 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.