I am trying a headless install and using NOOBS v1.4.2 .

I followed the instructions on this thread: Installing Raspbian from Noobs without display and changed the password on \os\Raspbian\os.json and kept the same username.

I found the IP of the PI over my network and tried to connect it by

ssh pi@192.168.x.x
pi@192.168.x.x's password: 
Permission denied, please try again.
pi@192.168.x.x's password: 
Permission denied, please try again.
pi@192.168.x.x's password: 
Permission denied (publickey,password).

I also tried the default password 'raspberry' .. still no luck

Is there something I am missing here? SSH seems to be working and activated on install. I made all the changes suggested on that thread. Still can't get anything though.

  • Did you try the default password ("raspberry")? – goldilocks Nov 13 '15 at 14:23
  • Forgot to mention that I tried that already (updated question to point that out) – Sud Nov 13 '15 at 14:34
  • Try it with ssh -v ... and edit in the output. – goldilocks Nov 13 '15 at 14:54
  • I read the link. It is very clever, but convoluted! Why would you want to go to this much trouble when you can just install Raspbian. NOOBS is really designed for people who don't have SD facilities to copy an image. – Milliways Nov 13 '15 at 23:10
  • I downloaded NOOBS when I had a keyboard and display around me. By the time I got to configure the Pi, I didn't have those accessories and was in a low-bandwidth place, so was not interested in spending a night downloading Raspbian! – Sud Nov 16 '15 at 4:31

The response you are getting is telling you the answer. You are not providing the correct password. This means one of the following has occurred:

  1. When you attempted to change the password, you did not do this correctly
  2. When you enter the password, you are not entering it correctly

Try starting over. I would suggest that you not change the pi's password until a later stage, after you have things set up for your intended use.

| improve this answer | |
  • That's right. I changed it as advised (in that tutorial) in the os.json file but that didn't work. The default was still on and I went into config to change it later. – Sud Nov 16 '15 at 4:30
  • Oh good. Enjoy! – donblanco Nov 16 '15 at 14:59

This could be related to the default UK keyboard used on the RPi. I used a special character in my password and this converted to " on the default UK keyboard and Locale. Make sure you set the Locale and Keyboard that match what you are actually using.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.