0

I have a brand new distribution of raspbian running on my raspberry pi,

When I do startx it loads a bit. Then I see the wastebasket, but the menus just flicker on and off.

I checked my user pi for the right groups and it is correctly setup I think audio video group were present along with others.

How can I fix this?

EDIT

The basic xterm works, but when trying to go into safe mode the screen stops working entirely for both commandline and startx

The Monitor model https://www.adafruit.com/product/2407

  • How are you viewing the screen? I am going to guess that you have an HDMI cable from your Pi to a monitor, based on the situation you described. It seems as if startx is working fine, but your connection has a problem which would cause the flicker. The other possibility is that the startx window is reloading rapidly over and over, which would cause the flickering appearance. It would be helpful if you could describe your setup, cables, etc. – donblanco Nov 15 '15 at 16:41
  • it's not a flicker.. this is the computer rendering things funny. It's just an HDMI cable going to an LCD touchscreen. Also seeing this behavior on my asus monitor. – Erik Nov 20 '15 at 18:41
  • Hi @Erik, since the post has been brought up again... Did you solve the problem - if so you can always write your own answer. Did you check goldilocks' suggestions? Any good news? Feel free to share. – Ghanima Dec 21 '15 at 11:20
  • @Ghanima added comments to his response. Will do further work before modifying my question. – Erik Dec 23 '15 at 9:03
  • Have you tried this pi with another display? Does it work anywhere? – goldilocks Dec 23 '15 at 10:49
1

Try something as minimal as possible. First:

sudo apt-get install xterm

Now create an xinitrc file for your current user:

echo '#!/bin/sh' > ~/.xinitrc
echo xterm >> ~/.xinitrc
chmod 755 ~/.xinitrc

Check that it looks like the below w/ cat ~/.xinitrc:

#!/bin/sh
xterm

Now, as the same user, try startx. You should end up with a plain black screen, an X shaped mouse cursor, and a (very primitive looking) black on white xterm window.

This is just to check if it is not something weird with the higher level GUI stuff. You can exit w/ ctrl-alt-backspace.

In any case, you could also try adding this to /boot/config.txt and rebooting:

gpu_mem=128
hdmi_safe=1

I'm presuming this is an HDMI monitor. Comment out any other hdmi_ or gpu_ lines by adding an # to the beginning.

If that works, have a look at the documentation for hdmi_group and hdmi_boost and experiment. You'll have to remove hdmi_safe first -- there is documentation for that on the same page -- and possibly experiment with setting some of the things that sets (e.g., hdmi_boost).

  • I used vim to create the file, got a black on white window with a mouse.. the mouse didn't respond to my touch inputs (but that's another matter) – Erik Dec 23 '15 at 9:03
  • current entries I have were given to me by the vendor/manuf. adafruit hdmi_group=2, hdmi_mode=1, hdmi_mode=87, hdmi_cvt 800 480 60 6 0 0 0 – Erik Dec 23 '15 at 9:05
  • going into safe mode made the display unusable entirely (commandline no longer works) – Erik Dec 23 '15 at 9:06
-2

Try reinstalling Rasbian Jessie or try apt-get update && apt-get upgrade

  • 1
    um, this is a fresh install with all patches/upgrades.. no – Erik Nov 20 '15 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.