1

I bought a PI2 to use it as a media streaming device for my TV. I've been fiddling around with it since the begging of summer and have been unable to set it up exactly as I want.

The (main) problem I'm currently facing is video stuttering while streaming (using KODI). It doesn't exactly stutter, the sound stops and video is slowed down. It' doesn't show a buffering message, and pausing to let it buffer doesn't help. It only happens when playing HD video.

Here's my setup and the troubleshooting I did: My pc is running linux and is connected to my wi-fi router (Asus rt-n12e) via ethernet. On the pc I have a ntfs drive that's shared using SMB (I'm planing to switch to NFS). My PI2 is in the other room, and it's connected to the home network using a wi-fi adaptor (Asus n10 nano). The PI is powered by a 2A tablet charger (this is like the 4th one I tried). Also I have a powered USB hard disk connected to the PI, but removing it doesn't help. I'm running Raspbian Jessie with 4.1.13-v7+ kernel, installed on a 32GB SanDisk Ultra sd card. I have 320MB RAM allocated for the GPU, and am running at 900MHz. KODI version is 15.1.

The most probable culprit for the problem I'm facing would be the wi-fi connection. When I test the network connection (using iperf) i get 70Mb/s down and 40Mb/s up (average over 100s). But tonight I was watching a 107min long 4.3GB mp4, which is ~6Mb/s and the issue occurred. I was monitoring the network usage at the time and it was around 8Mb/s pretty much constantly, before, during and after the stutter. Both the PC and PI were not under serious load at the time. Additionally when I returned to the "problematic" bit of the movie after finishing it, everything was fine...

Do you guys have any ideas what could be causing my issue? Thanks!

  • what profile/level is the video codec? RPi only handles up to High/4.1 I believe – Jaromanda X Nov 19 '15 at 5:48
  • 1
    I've had this problem, and it turned out that not having "Adjust display refresh rate to match video" in Playback settings was the culprit. – spender Nov 20 '15 at 1:35
  • Thanks, I'll check that as well. Meanwhile I changed the advancedsettings.xml file to increase the cache and it seems to be working fine. – Marko Kuzmanović Nov 20 '15 at 11:07
0

Just a head's up that if you made changes to advancedsetting.xml, in Kodi v17 they renamed tags used in advancesetting.xml

...so if you had made changes to buffer settings there, you'll need to add the new tags:

<cachemembuffersize> renamed to <memorysize>

<readbufferfactor> renamed to <readfactor>

EDIT: Also learned that these tags are now children in <cache> no longer in the <network> tag.

My advancedsetting.xml now looks like:

<?xml version="1.0" encoding="utf-8"?>
<advancedsettings>
        <network>
                <buffermode>3</buffermode>
        </network>
        <cache>
                <!--could find no docs if buffermode was moved out of network as well, so duplicating it here-->
                <buffermode>3</buffermode>
                <memorysize>0</memorysize>
                <readfactor>4.0</readfactor>
        </cache>
</advancedsettings>

Basically I turned off buffering and data is streamed directly to my microSD. Works great even for high bandwidth 1080p/DTS streams.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.