2

I recently tried to use a Raspberry Pi Model B+ as a gateway between the internet and some equipment. The idea was to have a 3G modem (Huawei E3531) connected to the internet, which works fine, and route the connection to my local network. On my local network I have a webserver, which I need to access from the internet, and therefore I need the 3G modem to allow INBOUND traffic. I have a SIM card with static IP address, so it is not a ISP problem.

But I found that the Huawei E3531 3G modem does not allow INBOUND traffic, and when I started to google the subject, it seems hard to find a 3G modem that allows inbound traffic.

EDIT: I used the term INBOUND out of context, by INBOUND I mean that you from the internet connect to the webserver on the static IP.

Which modem to select? Or is there any other clever way to do this ?

  • 2
    This doesnt make sense.. Internet CANNOT work without inbound traffic!? Either the modem is hard fire walled to block inbound 80 requests, or your mobile ISP is using carrier grade NAT, causing port hell (requests cannot be forwarded properly) I would try maybe create a SSH tunnel (Or reverse SSH Tunnel) to a test server, ie Digital Ocean, and relay traffic that way to overcome all the port blocking nonsense. Client > 80 > DigitalOcean > SSH/VPN > Pi > SSH/VPN > Digital Ocean > Client - Once you get the tunnel running you can think about how to overcome this in a long term way. Or IPv6 – Piotr Kula Nov 19 '15 at 9:40
  • Okay - By inbound traffic, I mean that you from the internet connect to the webserver on the static IP. Normally routers do not allow connections to be made from the internet and in, only the other way around, that is you connect from behind the router to the internet, and the reply is allowed. – JakobJ Nov 19 '15 at 10:01
  • 1
    What is the IP address of the 3G modem, I mean when yo do an ifconfing / ipconfig . If its private, ie, 192.x.x.x/10.x.x.x then its carrier grade NAT and you can thank your ISP for that, its common issue around the world which caused this issue you talk about. The dongle is a MODEM, not a Router. modems don't NAT or firewall, they provide full gateway access. But if they do then you should have access to these settings, but you may not if its a branded thing like O2,Verizon,Vodaphone,etc. Only consumer, unlocked ones will.. but I have never seen that. – Piotr Kula Nov 19 '15 at 10:07
  • The IP is in the 192.x.x.x range, but I can see on the modem configuation webpage 192.168.0.1, that is has an IP of 72.x.x.x or something. The Huawei modem presents itself as an ethernet device, with it's own DHCP ect., so it works as a small router. With a little private network between my PC and the 3G link. – JakobJ Nov 19 '15 at 10:09
  • 1
    Yea, 72.x.x.x. seems to be carrier grade, meaning that one IPv4 IP at the ISP shared across 1000+ people. Anyway, so if you can login to the setting page and there is no NAT, Forwarding or Firewall tab, then either it doesnt do that or its blocked from being edited. Like I mentioned before. Try setup a VPN, when the VPN connects to your endpoint you will see your real, shared IPv4 address. There is no way to bypass carrier grade NAT, cause you cant configure their routers. You can only use VPN/SSH Tunneling – Piotr Kula Nov 19 '15 at 10:14
1

Are you sure your Provider does not put you behind a NAT gateway ?

You must propably buy a special M2M tariff or use some kind of tunneling like ngrok or Reverse SSH tunneling . A VPN would propably work too.

  • Ended up using a reverse SSH-tunnel. – JakobJ Nov 25 '15 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.