1

I have tried establishing UART connection between my rpi and arduino mega, I tried to follow this tutorial {http://blog.oscarliang.net/raspberry-pi-and-arduino-connected-serial-gpio/}, where I use a voltage divider from 5v to 3,3V. Since I am using a new rasbian version i used the sudo raspi-config to disable serial, after I uploaded the same sketch in the tutorial to my arduino Mega, and connected the pins, I installed the minicom on my rpi and then I run the command minicom -b 9600 -o -D /dev/ttyAMA0, but I try to type something but receive the nothing on my console. I am not sure if my arduino is actually correctly connected to my rpi or where i am going wrong. I would really appreciate your help Thank you !

http://i.stack.imgur.com/7Uusi.jpg

  • 1
    A photo and a description of the connections you have made between the Pi and the Arduino will be useful. Could you add that detail to your question? – joan Nov 19 '15 at 11:09
  • I did edit my post, I hope the connections are visible – Mehdi Nov 19 '15 at 11:31
  • Have you programmed anything on the Arduino? And are you sure you have thw TX and RX set up correctly – Wilf Nov 19 '15 at 11:42
  • I wrote the code byte number = 0; void setup(){ Serial.begin(9600); } void loop(){ if (Serial.available()) { number = Serial.read(); Serial.print(“character recieved: “); Serial.println(number, DEC); } } – Mehdi Nov 19 '15 at 11:44
  • I made sure to set them correctly by setting the Tx of Arduino with the Rx of Rpi – Mehdi Nov 19 '15 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.